My Herelink Air unit is not pairing


I have powered my air unit with 5V and tried to pair it with my GCS but failed. when I press the button it flashes with LED2 and LED1 is stable and after a few seconds both LEDs are stable and an error shows like negotiation time out.

I have tried using flahware for upgrading as recommended but here also I got an error like “failed to connect to port 443 timed out”.
Failed to execute script flasher.

I have tried for so long to resolve but failed. kindly help me with this.
Thank You

Hi @MadRC my error is showing as Failed to connect to 443 timeout"
Can you please suggest to me the right full way to solve it

please check your internet connection, confirm it is working ok

Thank you so much @Michael_Oborne It is resolved now.
But now when I am trying to open the Qground app it is showing "compass primary error’ or there is a bug in your firmware. Can you please advise me on how to resolve it?

Also when I am trying to calibrate the RADIO, in the end, it is showing calibration fail. Your throttle is reversed. What to do here?

Kindly forgive me as i am completely new to HERELINK

This looks like autopilot’s problem. Please connect it to computer via USB cable and set it up there.

Please calibrate your Herelink sbus

There is a toggle switch REV to reverse it. Check this in Herelink Settings App > Joystick tab

Thank you so much @Alvin sir for your Help.
Except for “compass primary error”, everything is resolved now.
I arming my quadcopter by using the Herelink and after a few seconds, it is disarming by itself. What could be the error here?

I am testing all these on a bench without mounting propellers.

Maybe there is something wrong in compass calibration. Connect your autopilot to computer and GCS. Then check the compass page.