New Cube Firmware not loading

#1

We have just received the new cubes, with fixed hardware IMU issue, shipped from Hex factory late May 2019. When we plugged into the USB the Here2 GPS just flashes blue. Loading 3.6.9 firmware was not working and we were getting messages such as"is this a Linux board". There was some ray of hope when we installed ArduRover firmware which seemed to get the coms working. Following this, we did successfully install Copter 3.6.9. But when we installed our custom 3.5.5 firmware (always worked with older cubes) and it went back to flashing the blue light on the Here GPS. Now we cannot install any firmware and get messages again “is this a Linux board” followed by error messages. For experimental purpose, we have to load the older custom firmware 3.5.5 which has always worked. Does anyone know who may have recently purchased a Cube Black (Late May 2019 onward) if you have had similar issues? And do you know if the new Cube Black is compatible with older firmware?

#2

Have you installed the latest Drivers for Mission planner and latest Mission planner ?

Also your 3.5.5 is using NuttX and is not recommended at all now, you will not be able to take full advantage of running all thee EKFs for the full redundancy or get the changes in the latest Version to help IMU switching.

You really need to base any new versions around today’s latest.

#3

Hi MadRC. Thank you, and I really enjoy your videos. Your contribution has been really valued.

Yes we have installed the latest MP MSI. And yes we know about the Nuttx and prefer Chibios, but unfortunately we don’t have a choice and its been discussed with the Proficnc. We all expected it to work like normal, but its not. So very surprised and need to understand why.

#4

Have you forced the boot loader, i would flash a known stable release of 3.5 with forced boot loader and then update to your custom one, your going to have to choose no to Cube Black and then follow that through.

I have seen this my self actually but it went with a reboot, If you get the Linux question try as follows.

Cancel the install in MP at that question, unplug the board, then select the update again and plug in when asked and you should get the Cube Black option next time.

#5

After trying various things as suggested we did sometimes get our custom 3.5.5 code to program, but at the point where it says “Please wait for the musical tones to finish before clicking OK” it becomes mute. The blue lights on the Here2 just continue to slow flash. After that no com ports display so we cannot connect to the vehicle, so reloading firmware is again difficult. It seems there is something not compatible with the older 3.5.5 custom firmware which we have used successfully many times before and believe is stable. There is a “sort of” similar post in https://discuss.ardupilot.org/t/new-cube-black-pixhawk-2-1-cube-install-firmware-hangs-reading-hex/40548/9. Its likely if these new Cubes came pro-programmed like they used to we probably would not have this issue. Could we be loading different IO firmware? Many thanks

#6

I had this issue with my first cube (currently being RMA’d for Service bulletin). I found that when the ‘wait for musical tone’ message came up, I simply ignored it and immediately hit connect in mission planner (don’t even disconnect the USB cable). It was repeatable for me and connected successfully. After that, I was able to disconnect usb, power cycle, and connect with no problems.

#7

Flashing blue suggests it’s taking the firmware ok.

I have a feeling this is a driver issue after downgrading back to older PX4 based.

If you can try as follows and downgrade it then connect it to a fresh computer with just mission planner installed and the drivers but not been connected with Chibios firmware cube.

If you can’t do this look at it once downloaded to your version in device manager and look at the com ports.

I suspect your computer have driver issues when you have downgraded hens why you can’t connect.

If it was flashing orange then I would be betting firmware but as it not and blue I think it’s ok. As for the sounds they may not always play in my experience with some things as I recall it’s related to the IO firmware. But could be wrong on that.

#8

For what its worth, Ive never had any sounds play on my Cubes after “wait for musical tone” message. When I first started with the cube, I left it for up to an hour with no tones. Now I just ignore that message and i haven’t had a problem.

#9

Hi Ekliptiko. Thank you. Not getting tones is an indication to us somethings different. If we recycle power after loading custom 3.5.5 the Cube does not boot up like it should. Nothing works including the coms, so we cannot access the params. All that happens is a slow flash of the blue lights on the Here2 GPS. The problem we are having is a combination of 2 things 1) Recently build Cube (Post 2019 IMU issue), and 2) older stable custom firmware 3.5.5. Change to an older cube or latest firmware and it works. Unfortunately we are stuck with 3.5.5.

#10

Hi MadRC. Once again thanks, its really appreciated. I realized I did not exactly follow your instructions as I should have, but I will do it again. I did use our old PC which had an older version of Mission Planner (ends with 56). I started with 3.6.9 on the new Cube. The result was exactly the same. No activity after loading in custom 3.5.5. I tested it with an older cube and it worked OK.

#11

Hi, problem is resolved. The bootloader needed to be downgraded for the new Cubes to work with 3.5.5 custom fw. Many thanks to the Proficnc team for their help. And looking forward to moving to 3.6.9 custom using ChibiOS as soon as we possibly can.

1 Like