New Herelink Setup Nightmare

After eagerly unboxing my new Herelink and explicitly following the wiki setup instructions it will not connect to QGC or Solex and gives the message ‘Waiting For Vehicle Connection’.

My setup is as follows.

Herelink Air unit connections:

UART to Black Cube Telem 2. Serial2 protocol = 1. As far as the baud rates I have tried most of them.

To my knowledge there is no documentation which describes how to connect a Herelink into a cube other than to plug it into a Telem port. Both products are made by Proficnc but you don’t describe how to setup the connection!

sBus1 to Cube RCIN

sBus 2 to Gremsy gimbal

12V power supply connected.

Cube running Copter 4.0.3

The Controller is paired.

When turning the Controller off the Cube will Beep so there is some sort of connection?

The Air Unit LED2 is green. LED1 is very dim.

During the install I carried out all the uploads, pairing, calibrations, button setting etc twice and get the same ‘Waiting For Vehicle Connection’ message.

I also get this error message.

QGroundcontrol Error

This system is basically an Android device which normally can be up and running soon after unboxing. With the Herelink you have to work through multiple web setup pages, watch videos and run setup programs, preform updates, calibrations and whole lot more then to find it won’t work. For a quality product like this it should be plug and play out of the box instead it is a time consuming nightmare!

I have also found the following.

The air unit mounting bracket looks great, but the screws are too long and wont’ screw into the paint filled holes. There is no slot in the screw top so you can’t tighten them.

The Key is printed on microscopic sicker stuck on the cellophane packaging which is the first thing to be binned and lost.

There is no power supply included. Who uses 3S on a copter? The cube comes with a power brick and even Gremsy supply a 12v UBEC.

There is no SD card supplied.

The solution to last two issues is to buy a UBEC and SD card from another vendor so the Herelink will work.

Putting aside the above issues I would like to get my Herelink working.

If anyone can help, I would appreciate it!

Baud = 57600,115200, or 38400
the connection is plug and play.

You do not need an SD card for it to fully function.

2S or 3S direct lipo connection is the preferred option,

the ideal connection is s-bus1 to the cube, and cube s.bus_out to the gremsy
this is related to our build, and is not relevant, future builds will remove this warning.

please show photos of what you mean here, I suspect you are talking about the supplied screws to mount an optional fan, the head is blank so it fits in the special slots on the top.

I stand corrected about the screws but i’m more interested in getting QGC connected.
If it is Plug and Play why doesn’t it play?

OK thanks for the info on the error window.

You can power the Air Module off of 3S? I’m using a Castle BEC set at 8 volts. I do fly on 3S but was afraid a full charge at 12.6 would be to much voltage for the Air Module.

1 Like


I have been trying to do some trouble shooting with no success and QGC/Solex still won’t connect. I checked the UART and sBUS cables for continuity plus the connectors and they seem OK. The input voltage is just under 12V. Also I have tried connecting the UART cable to Telem1 and Telem2 at 57600,115200, and 38400 Bauds while rebooting in between changes.

I notice when I flashed the updates, a window opens which shows the progress. The updates all seemed to go OK but then the window closes. There is no indication if the updates were successful or failed. Is this normal?

The controller shows it is paired but the Air unit LED1 has no light which would indicate no flight controller signal.

LED2 looks like it is steady yellow which would indicate no valid signal.

This all looks like an Air Unit – Cube connection problem and I ask if anyone can help further?

check you didnt enable rts/cts on the telem ports on the cube or anything odd

Solved it which unfortunately was a self-induced wiring issue. :-(. Buying some stronger glasses tomorrow. Philip and others thanks for your help and it looks a great system.

Where would someone find these special screws to attach the fan to the air unit. I don’t know if I lost them or never got any with my second Herelink. I’ve looked all over the place and can’t seem to find anything like them. Thanks

You will need to contact your reseller.

Even if they were purchased a couple years ago? I have a set for one of them but I don’t know if I lost or didn’t get a set for my other Herelink. And then I’m going to figure out which one of the dealers I buy my Hex/Proficnc products.

All sales and spares are via our resellers

Hi @Robert470
I think @philip reply is appalling.
I’m sure he knows exactly what the screws you need are and could have easily have given you the details so you could source them yourself or via a reseller.
Maybe it shows ProfiCNC are more than happy to sell you their products but as for support, forget it!!

Why the hostility?
All our resellers know what the screws are and can help him.

Maybe you haven’t noticed, but our reseller network is made up of the community that make Ardupilot what it is. They are developers, users, and contributors.

We don’t step on their toes, we don’t bypass them.

Parts, and services come from our resellers.

If you asked Honda about getting some parts for a car… they would recommend you go to your local dealer…

May I ask how this is different?

The screws are custom made for HereLink… not something you can buy at a hardware store.

So is my answer still appalling?