No GPS and telemetry problems

I have a Pixhawk Cube Orange, Holybros M8M and RFD 900x telemetry system. And I have been dealing with multiple problems since it all came in the mail. And all of this is with MP and Q. And I have been trying every think I can find online and in the manual.

  1. I had problems with the gps showing location, and when it did MP still gave no gps message. And now wont get gps lock at all. And I have been trying every think I can find online and in the manual.
  2. Telemetry modem does not connect to MP or Q, and because of that I don’t know if they are connecting to each other.
  3. After fighting with it it does not connect to Q any more. If I try to update the firmware it shows the board but still doesn’t connect.
    And for all the above problems I have tried flashing the board on MP and Q. Any help is very appreciated. I am at my wits end and just want to get it all working or replaced. Thank you for any help.

Check your GPS parameters are correctly set. Or directly connect the ublox chip inside the GPS, to see if it is working, whatever how to do this on that module.

For the telemetry, connect your Cube with USB and check whether the telem parameters (eg: baud) are correctly set.

Are there any parameters that you would suggest looking at? And would you suggest using Q or MP for tracking down the problems and long term use?
I will check that parameter and get back to you.

I am using telem 2 on the board. It is currently set to 57600. Is that a good value?

Read the manual or ask the manufacturer of the GPS module you’re using. There should be a way to direct access to the ublox inside.

For the telemetry, 57600 should be the default baud rate for RFD900x.

Connect it to verify.