No gps detected


I have some issues with my gps, when I do calibration, it seems like it’s working.

But mission planner says No gps when it’s pre-arming.
For information, I soldered the wires of the gps to wires going on the connector of the cube (It may be the problem, like bad solder or wires inversion even if I don’t think so)
By the way, I have this in EKV doing nothing.

If you have some ideas, please tell me, ty.

We need a lot more info than this.

An you post the controller and the GPS model.

Connection serial or CAN ?

When you can you have calibrated the GPS does not get calibrated. The compass does and while these are in the same housing they are independent sensors on the GPS1 port and have different data bus types.

Can you post the DF log file? I think we had a similar issue in the past could try to help out.

The controller is orange cube, the GPS is a CUAV GPS/Compass and I connected it on GPS2 on the controller

(I didn’t understand your last sentences)

@uavgarage What are the DF log file ?

I think the one with SPI bus type is my GPS

Please remember GPS and Compass are separate devices internally, the SPI is the internal compass, the GPS is on UART and wont show there.

The info you suggest says the the GPS wiring may not be correct.

See the port pinout

SPI is all CubeOrange. Try interchanging Rx & Tx on your serial port for GPS to work. Compass is usually on I2C which you need to connect separately.


I found this for my gps, can you tell me which one are for the compass and for gps ?
And if Tx of my gps go on tx or rx ? because currently its Tx to Rx and Rx to Tx

Also, can all be connected to GPS1 ? Because the compass working, maybe it’s just 2 wires to modify ?

EDIT : then I’ll try to solder again

Green and Yellow== GPS(Serial)
Orange and White== Compass(I2C)

The SCL and SDA are I2C for the compass, TX and RX will be GPS. so see as below

SCL Goes to SCL
TX Goes to RX
RX Goes to TX

So there will be 2 wires on I2C and 4 wires to GPS2 ?

I’ll try and modify as @MadRC suggested.

Get you in touch, thanks

6 wires in total.

Tx and RX crosses for the GPS
SCL and SDA 1-1 for Compass
Power + and -

Yes, that’s it

I did it, 4 wires on GPS1 (cause GPS1 and GPS2 seems different from your doc on port pinout)

and 2 wires on I2C, now I am trying

I recalibrated the compass, but still no GPS …

EDIT : It must be the GPS Tx not working cause I receive no information, I try to solder it again

Still no GPS detected…
@MadRC @Mallikarjun_SE

Are you on GPS 2 port still ?

Have you enabled the port in the Prams as GPS2 is disabled as standard.

I am on GPS1 as shows in the picture

Can you interchange Rx and Tx wires? Also check GPS_TYPE is set to ublox or Auto.

@Mallikarjun_SE Okay, it seems like it’s working now, I did the Rx and Tx swap, and GPS_TYPE was already auto. Now it says No fix GPS but I think this is just because I am indoor. Thanks for all

EDIT : I have bad EKF Vibe, what does it mean ? ( I have EKF in red color, and when I click on, I have this : ekf

Once you are outside, It will be sorted.