No SBUS connection between air unit and cube

I have used my Herelink (most recent stabele ver.) before and did all the calibrations connections fine several times.

But now I did a rebuild of the copter and can’t get the SBUS/RCIN to run.

Telemetry, Mavlink etc works fine, stable wireless connection. But I get RC failsafe and in Missionplanner all RCINs are 0 and cant do the RC calibration.

Re-paired the air-unit, re-did all the hardware- and SBUS calibrations several times, checked/ replaced the wire connections (they are correct, RC signal was working a week ago). I set the wheel to SBUS2 to have something on there and tried it with the air units second output. I set a serial port of the AP to RCIN function (100K, Rx inverted). I tried all that on the black cube, which was working before, with ardupilot copter stable, I tried all again on another AP. Also no luck. I tried it with the cube completely set up and also with only the air unit connected to the cube.

So I concluded it must be a problem with the air unit and I hooked up an oscilloscope to to the SBUS outputs and get a square signal, so something seems to be coming out of there.

Any suggestions what else I can try?

Flashing the air unit again did not help.

But I now found an IBUS receiver and connected it to the cube and also have no RCIN connection.

Since this issue now involves two FCs and two receivers I am no longer sure if it has to do with the herelink or with ardupilot and will repost the issue over there and paste the link here for reference.

Here the param file, but I think it has nothing to do with that, i also tried SBUS out to 50Hz.

https://1drv.ms/u/s!AuKkq6JXpbFTzvEXR3JkL3qRDipDcQ?e=Wb93uk

Can you try to flash both air unit and controller again?
Also, verify if the sbus cable is connected correctly.

I solved this, the herelink is fine.

On the black cube i think i had the RCIN reversed, the marking seems counterintuitive on the mini carrier board, but maybe thats just me.

On the 3rd party FC with F7 core, the SERIAL5_PROTOCOL had to stay configured as -1. Seemingly it needs to stay reserved to RCIN. Now all works fine.