No Servo Output on Cube Black Pixhawk

Hey everyone,

I’m pretty new to the whole pixhawk community. A project I’m working on has me using the Cube Black pixhawk. I saw the service bulletin that grounded all the cube blacks and I have followed the instructions through that thread. I’m running the latest version of Ardupilot, I’m using mission planner V1.3.66 with Arduplane V3.9.8 (6ea22c9c), and I have updated all the parameters accordingly. I received no error message from mission planner asking me if I wanted to report. I’m still just trying to do an electronics test before I put everything in the aircraft. So I’m not trying to fly right now, just making sure that everything works beforehand.

At any rate, I connect the transmitter and am bound to the receiver, I have connected via mav link and can see the different channels responding as they should in the Radio Calibration screen of the initial set up tab. I calibrated the radio. But when I move to the Servo Output screen, I get no response from moving the sticks or the switches. I’ve plugged in good esc’s and servos that I have tested on other platforms, but they do not respond on the cube black. Lastly, I probed the pins with a multimeter to try and see if I was getting power to the main and aux output pins and I’m reading between 7-14 millivolts.

Is there something else I need to enable in the parameters perhaps? or is there something else I’m missing? Any guidance would be very helpful, I’m happy to send information about the set up, keep in mind though, I’m a newbie to this stuff, so please be patient with me.


There is no power to servo rail for servos. Have you provided power with bec to the servo rail. Also you may need safety switch on

Safety button?

Hey guys,

Thanks for the quick response. To answer your questions, I think I have power provided to the servo rail. The BEC is plugged into power 1 on the pixhawk. I don’t know if there is more I need to do to power the rail. I didn’t have the safety switch in the first time. I just tried that and I’m still not getting any output or control of the servo or esc. The servo ins’t evern centering when I plug it in to the rail.

Power 1 and power 2 will not power the servo rail! Separate bec to servo rail is required.

Power one is for the flight controller, the Servo rail needs its own power, normally from the ESC BEC, but you need one big enough for your servos.

If you do not have a safety switch, have you disabled it in the parameters? Unless it is specifically disabled, it will never allow you to send PWM.

Why do you not have a safety switch connected?

There is one either on the here gps, or on the supplied alternative cable.

Plug it in… if the light is flashing red, then press the button…

And power your servo rail

Okay, I have connected power to the rail from the ESC BEC. I am measuring 4.85 V coming off of the power from the BEC before plugging it into the rail. This makes sense to me since most, if not all, servos run on 5V power. I’m assuming that like other receiver rails I can plug that lead from the BEC into any of the main pin locations and it should power the entire rail. Is that correct? When I plug the BEC into the rail and measure the voltage across the negative and positive pins though, the voltage measurement is only 1.5 V. I didn’t have anything else plugged into the rail that would be interfering with voltage. The only other thing plugged into that that side of the pixhawk is the RC in and Power One, which shouldn’t do anything to affect the power to the servo rail if I’m understanding you correctly.

I double checked that the safety switch is enabled in the parameters and I’m using the safety switch button that is plugged into the GPS1 port, and I’m ensuring the light is solid before testing.

Thanks again for all your help.

Okay. So I have figured out power to the rail and am running into a different issue now.

I can control the servos through the pixhawk and everything looks good on the servo output for the elevator and the ailerons, but when I cycle the throttle, that signal doesn’t move on the servo output screen. However, when I look at the Radio Calibration screen and cycle the throttle I can see the throttle signal moving, indicating that the pixhawk is receiving signal from the transmitter.

I’ve looked around for throttle fail safes and can’t see any that are enabled. Is there somewhere I should look for that?

Thanks again.

Throttle will only work after arming

Hey Guys,

Thanks for your help and direction. I think we got it working for a bench test. We thought we were armed initially, but there were a few checks that were preventing arming that we had to troubleshoot for a little bit. I have it working now.

Thanks again.

1 Like

How did you manage?, im stuck in that point with the CUBE orange, and I cant find a way to fix it. Help please, Im super frustrated at this point.

In the list of parameters. We had to disable the arm_check command. That allowed us to manually check subsystems before arming, Then we manually armed the system with the arm_rudder option once all the pre-flight checks were done. Once we had the system armed, everything was fine.