No signals from S.Bus reciever - Futaba R2008SB

New build here - also first time builder so keep that in mind.

Brand new CubeOrange.
Followed the user manual setup but when I get the the RC Config I get no lines or data of any kind.

Using Futaba R2008SB, with T8J and Futaba confirmed that no settings are required for S.Bus to be active.

I see S.Bus Packets when connected to an oscilloscope but I don’t have a RX tester.

Is there a setting on Ardupilot I missed or what else could be an issue.

Thanks Tristan.

Solved. unplugging and reinstalling the 3rd time solved it ( HPFM)

No how to calibrate the ESC ? what LEDs are described in the manual?
“The autopilot’s red, blue and yellow LEDs will light up in a cyclical pattern”
I only have LED’s under the Cube orange and on there HERE3.

Also how to put in ESC Calibration mode when I don’t have a safety switch?

Thanks, Tristan.

ESC Calibration was solved by using the included switch and reversing the throttle on RC TX.

Here 3 Manual states to disable BRD_SAFETYENABLE but this parameter is not available.

Is there any support for this device? or am I on my own? ( Bueller???)

There’s plenty of support, mostly over at for the Ardupilot firmware, and for the PX4 firmware should you choose to use it

BRD_SAFETYENABLE,0 also definitely exists, you’ll find it in the Full parameter list of MissionPlanner, also all parameters are available in QGC but they get broken up into some level of “difficulty” or common usage.
You might as well find it and set it to 0 (or disabled) and leave the safety switch out of you build, since it’s more like anti-safety.

The ESC calibration is best done with the “semi-automatic” which ironically is the most automatic of all methods: