No video in solex

Hi everyone- I am running a cube Orange with a herelink and I have a goPro hero 7 black which is connected to HDMI 1 on the air unit. I can open QGC and the video streams with no issue. However, I just started playing with Solex and I cant get a video stream. I get an error that says “timed out waiting for stream info. try again”. I double checked that it is set to HDMI 1 on Solex. Just to make sure that QGC closed completely I rebooted the herelink and the only opened Solex and still got the same result. Any ideas on what I could be missing?

At times QGC can steel the video in the background but it should be fine if your opening Solex on its own after a reboot.

Try after rebooting going into settings and App and find QGC and make sure QGC is shut down before trying again.

Also make sure it’s looking at the first input.

Yeah, I tried both of those things with no luck. I even tried resetting the camera and air unit. I tried turning on the camera before the air unit and after. I adjusted the frame rate on the camera side. Still no luck. But as soon as I open QGC it works right away.

Here is a video showing what I get with solex.

I was actually able to get it to work but it took a specific sequence. I have to get the herelink all fired up and the camera turned on. Then turn on Solex and THEN plug in the HDMI into the camera. This worked and the video came up. For reasons I can not explain QGC jsut works and does not care about the sequence and I can leave things plugged in all the time. But Solex I have to remove the HDMI cable and then replace it once everything is turned on. Kind of a fussy process but I am going to call this solved.