Orange Cube - Failed to update IO Firmware, fix it and than reboot

Hi all.

I have an issue.
I have today downloaded and installed latest (stable) version of Mission Planner software and Arduplane 4.3 firmware for Pixhawk Orange Cube.
Once I Connect Orange Cube to PC, I see “Failed to update IO firmware, fix it and than reboot” into Mission Planner Messages.
I am unable to calibrate sensor (accelerometer, compass). Have anyone experienced this problem ? How can I fix ? Thanks

1 Like

May I ask ,is there any disconnection during firmware upgrade?
Did this issue happend on other firmware(like copter)?

I’m having the same problem with my Cube Orange. I was setting some parameters in Mssion Planner a few days ago and then it suddenly lost connection without any apparent reason and it wouldn’t re-connect. My PC wouldn’t even detect the board when I plugged in via USB and tried to find it in Windows Device Manager “Ports”. After doing some digging I found out that the drivers to connect had gotten messed up somehow. I cleared the drivers in Mission Planner and re-installed and I was able to connect to the Cube in Mission Planner again. But now when I connect it gives me the exact same error message that Enga described in their post above: “Config Error: Failed to update IO firmware”. I’m not sure why or how this whole thing happened considering that I never even tried to update the firmware to begin with. So I’ve tried re-flashing the latest FW (Copter V4.3.4 OFFICIAL) dozens of times, I even tried flashing the other firmwares (Rover, Plane, etc) and it either fails to flash completely, or it successfully flashes but keeps giving the same Config Error message. And when I try to select the frame type that I’m flying (‘X’,‘Y6A’ Hexacopter) it gives the error “Set FRAME_CLASS OR FRAME_TYPE Failed”. I’m running Mission Planner 1.3.79 build 1.3.8375.24878 (43447be8).
I’m completely lost at this point and I’m just trying to figure out if it’s a software/firmware problem, or a hardware failure. Please Help!

Same problem I’m facing any solution please post

I think my Cube Orange Standard may have lost connection during a firmware update because it was doing it’s thing when the Cube suddenly powered off and my PC wouldn’t detect it when plugging it in. Somehow the drivers to be able to connect disappeared. Got drivers fixed and can connect to PC and Mission Planner now, but it consistently gives me the “Failed to Update IO firmware” message when I flash it with the latest version of Copter.
I spoke to one of the Cube developers on Facebook and he suggested sending it back to the retailer that I bought it from for warranty repair/replacement. I tried contacting the retailer but was unable to reach anyone.

Is there a way to recover my Cube if it gets bricked from losing connection during an update? I hope I didn’t just lose $500 lol :sweat_smile:

@Atownammo it should not be possible to brick the Cube through firmware update. If its stopped mid firmware update, the Cube will stay in bootloader mode, and can be updated simply by repeating the update process.

The issue you are facing seems to be unrelated to standard firmware update process.

hello;

@sidbh i have the same problem now, the IMUs and Compass are without ID’s… can’t calibrate them.

i flashed the PX4 firmware, it’s working perfectly there… so i don’t think it’s a hardware issue.

what could be the problem with mission planner ?

after flashing PX4, i flashed the arducopter 4.4.4 it connects to mission planner witout problems, but this message : config error : failed to update IO firmware.

thanks.