Orange Cube PX4 Receiver and Setup

Trying to setup a new build, on a Tarot X6 frame .Orange cube has a Here 3 , TX is X9D+ 2019, & plugged in (RCIN Port) Tried two receivers an R8 Pro and an R-XSR shows no movement showing on Mission planner, " radio calibration “, What I tried: firmware upgrades on Orange cube Hexa copter, X9D even the R8 Pro. following many you tube videos and all the settings for their builds that might apply to mine.
at one point with the R8 pro I clicked on the R8 on the radio menu and changed the output from sbus to F something and the radio showed as working in mission planner, but after a reboot that stopped, when I click on “Radio calibration” I can see the green bars for a split second. maybe I flashed the orange cube wrong, there are three choices “orange cube” Orange Cubedshot” or legacy ??
Thanks for any help here

I don’t give up easy, it works with a radiomaster TX16S and R81 RX , seems the accelerometer and compass calibrated, even ESC calibrated. But motor test , nothing moves?

Can you confirm your receiver is sending supported protocols to autopilot?

I don’t know why the X9D Plus 2019 taranis with access RX would not communicate, but looking at the pages you sent “access is not mentioned” , I switched to a D8 protocol using an R81 RX and Radiomaster TX16s , and the radio works as it should , the bars are showing in “mission Planner” also with a "cheapo Betafpv Lite 2 SE " TX , both of those Radios with the R81 RX work, I think the Orange cube does not like “access receivers”
Now I am farther along , Though the motor test will not run,
I can arm the drone with the Right rudder on Radio,
trying to find how to “Arm” with a switch and “Landing gear” doesn’t function, But in (Data tab, mission planner/ messages it shows as if its working when I switch SC which is set as mode RC_7. , but landing legs do not move, the power distribution box to the ESCs and landing legs plugs into I2C-2 on the PX4 maybe its not sending out right or the legs aren’t right, they just plug in? how can I troubleshoot the switches for ARM and Landing Gear ?? I’m closer, not there yet, was gonna start another topic , But since you answered !! Thanks

Another question, on the Parameter line brd_type what is the correct setting for my Orange Cube PX4, ? its been set to (3), but it says (0) will default it as a PX4 , (3) is for cube/px2 ?
changing it probably means I need to re-calibrate everything ?

Ok got it working, left BRD where it was, the landing gear not working was because it needed the three wires from landing control board (TL8X002) to a servo output pin 1 of the PX4/cube board, I changed a few setting in “parameters list”, SERVO9 29 RC09 29 then in user parameters picked RC8, now switch SD moves the legs. I don’t know if this info is somewhere in the many documents online, I googled the TL8X002 and Cube Orange and some guy had posted that he did this but wanted to make it Auto retract I think.

The landing gear setup is mentioned in Ardupilot wiki

Hi Alvin thanks for the response, the landing gear is working. I also have a drop device its just a servo with three wires, I ran Red and Black from a power wire going into Power 1 (spliced in to 5v wire),
trying to setup the drop device servo to a switch on my TX16s Radio, using an Aux pin for signal, testing on my existing, working landing gear switch now set to Aux 1 bottom pin. The servo opens but does not reverse to close? I probably need to read a wiki about servos now (PWMs, etc), its like being back in school (I hated school). assuming the servo doesn’t have built in end points in it then it needs some settings to tell it what to do?
I’m not sure is the servo is :Bad, but since it moves to full open from the landing gear pin, I think it needs its own programmed settings,
anyway I saw a link about using the camera shutter to control a drop device, what settings can accomplish the opening and closing of the servo device (MD752 servo)

In reading about servos and PWMs, I think the selective settings are preset PWMs, the landing gear moves when switched, but that same PWM will not operate a plain 5V servo open and close (though I think it should) , Once I figure this out I will make a video to help people , to simplify setup. Personally I think many existing Info and videos are created in a confusing way, people talk fast and say things like "so I set it to channel 7 and Radio 8 port 9 and 11 and wallah it works) , I just get lost when things don’t make sense. You would think RC7, radio7. Servo 7 , Aux 7 should at least have some common sense in a tutorial. Simple would be "Set Aux 1 to RC 4 in this menu and on your radio set SD to? and maybe a servo settings that matched one of these. But no nothing matches anything , to a newbie nothing makes sense. To my shame I am a TV technician for over 40 years, DJI drone tech last 6 years, dabling in racing drones last few. I’ll keep reading, testing and figure it out, These forums are actually the only real help available , if only things were dummed down a little. or maybe my reading comprehension is not that good? Thanks for listening to my ramblings Have a nice year

The company that sold my client the drop system, provides tech support and setup, will see how that goes. later this week

I agree that the ardupilot tutorials are kind of confusing. However it is an opensource programme and people don’t get paid to make contents.
Maybe you can make some pull request to Ardupilot wiki to improve the presentation.