Orange CUBE starts only one motor

Hi All,
I’m facing with ESC calibration problem with Orange Cube sit on regular mount.
I have build QUAD X , using DJI OPTO ESC 30A.
Setting via Mission planner set to QUAD X. running on firmware 4.1.4Quad.

All ESC and motors working and checked separately.
after performing ESC calibration, only one motor M1 starts after the calibration and 3 other continue beeping.

When i swap the connectors M1 with M2 on the Main out, the motor 2 start to spin.
I have checked servo setting in the mission planner and they are correct.

My thoughts that only M1 port send the PWM signal to the esc.

Maybe some of you face with this issue and have some solution.

Can you try to spin the motors via Mission Planner > Setup > Motor Test page?
Which PWMout ports are you connecting?

Hi Alvin,

I try to do the check via Motor test either only M1 motor spin, all others M2, M3, M4 no response and ESC’s still beeping.

Ports that motors are connecting, usual ports for QUAD X setup, MAINOUT 1~4( all wiring correct, ground cable up, no 5v, signal down )

Done swap between Cubes on the same mount, Installed Black CUBE from my other QUAD X, and all motors connected to the same ports, all motors working correctly. so the mount isn’t an issue.

Done Load params from CUBE black to Orange, still no success, only one motor M1 spinning.

Done downgrade firmware from QUAD 4.1.4 to 4.0.0 cube orange, no success.

Serial number of the ORANGE CUBE ( CU11J9800272 ) on left side of the cube there is a sticker “CubePilot, CubeBeta Tester”

The beep sound indicates the ESCs are not receiving signals. In Mission Planner > Setup > Servo Output, do you see all 4 channels are green?

Electronic Speed Controller (ESC) Calibration — Copter documentation.

  • Some ESCs like the DJI Opto ESCs do not require and do not support calibration, so skip this page completely.

I guess you are not suppose to calibrate DJI Opto ESCs as normal Ardupilot ESC calibration? Maybe you can try to reset them to factory default then try again.

I made swap between cubes, take the black CUBE from my other QUAD X and install it on the QUAD with DJI OPTO ESC, and the ESC calibration work well, also the motor test via MP working correctly, include arming, all motors spinning.

Than installed the ORANGE CUBE to QUAD X with MAD AMPX 40A pro ESC’s setup, and its still not working correctly, the calibration work only for M1 motor only all other esc’s beeping, also cannot run M2, M3, M4 motor via MP, and when perform arming, only M1 motor spinning.

Probably it’s faulted cube.

Did you reset all parameters and reload the firmware when switching the Cube?
Also, Can you try to assign Motor 2-4 to other PWM OUT such as MAIN OUT 5-7?

Hi,
Yes i try to reload different firmwares, no success.
Also upload other params, no success.
How can i open a ticket or send the cube for inspection?

Please contact your reseller for RMA.

Hi Alvin, can you tell me if Orange cube S/N CU11J9800272 sold buy what reseller.