Orange cube with a skydroid radio telemetry issue

Hi everyone

I have an orange cube running arducopter 4.0.5 connected to a skydroid receiver of an H12 radio

When using the ground station app to connect, it first connects I can see the data coming in then keeps reconnecting, data is there but just disconnects and reconnects nonstop

I connected the skydroid reciever to some cheap pixhawk FC and it worked with no issues, usual mavlink telemetry.

The receiver looks just like that of a Skydroid T12 radio not sure if there’s any differences tho.

I thought the ADSB could be causing issues so I turned it off but nothing changed

What could be the issue since it’s a normal telemetry connection

heres a video:

Can you verify if the SERIALx_PROTOCOL are set correctly?

Also, you may try to supply power to the telemetry separately.

1 Like

I tried both 1 & 2 which is mavlink1 & mavlink2
What do you mean supply power separately?
I have the airunit (TX, RX and Gnd) connected to TELEM1 of the orange cube
SBUS VCC and Gnd connected to SBUS input

Should remove the VCC and GND connections and use a BEC instead?

Try a bec, also it the ADSB carrier board ?

If so try disabling Serial 5 and the ADSB and seeing if it’s the same. It’s possible their software is not liking the ADSB hart beat on Mavlink.

1 Like

That was IT! I only disabled ADSB first, but now after disabling Serial 5 too it worked, the ADSB heartbeat was causing the disconnection, thank you!