Pixhawk Cube not flashing firmware

We have a pixhawk cube (black) which is working fine with its current firmware. Now, we would like to upgrade the firmware to a new version for a multi-rotor setup. However, this upgrade is failing. As suggested on forums, we have tried multiple versions (old and latest) of mission planner and Q-groundcontrol on Ubuntu, Mac and Windows but non of them worked. Also used different USB cables. It seems like it is failing to connect to the bootloader. The device manager or lsusb shows STMicroelectronics STM32F407 as connected device.

Qgroundcontrol gives the following in the frimware upgrade section:
Found device: ArduPilot ChibiOS (console mentions: “ArduPilot” “fmuv2”)
Error: Sync: Send Command: Invalid sync response: 0x53 0x75
Upgrade cancelled!

Is there any way to recover this pixhawk2 cube? Ultimately maybe reprogramming the bootloader via JTAG?

You may try to use the Bootloader Update option from Mission Planner > Install firmware page.

Ultimately maybe reprogramming the bootloader via JTAG?

This is possible. You will also need a ST-Link

Thanks for your response. I actually already tried that upgrade button in Mission Planner but with no success. Is there somewhere a how-to manual and maybe a reference to such a programmer that we can buy?

I would recommend requesting an RMA from your local distributor because the connector is not easy to get.