Pixhawk Cube orange does not boot up

Continuing the discussion from Pixhawk cube orange won’t boot up:
I’ve tried every available solution and still can’t get there. I tried replacing the SD card but had no luck, Tried flashing every type and version of firmware but every time it says the same, “already on the board” and this is a really essential project that I am working on, therefore I need to solve it as soon as possible. Any leads would be much appreciated.

Is the cube plugged into the carrier board?

Yesss the cube is plugged into the carrier board…

Can you try to load px4 then back to ardupilot?

I had a couple of anomy’s like that happen to me too. But I worked on it as soon as I got it and returned it within the 30 days. It was firstly booted up and wouldn’t arm. Then it got so bad it wouldn’t initialize. Couldn’t find a fix and it’s my 13th Orange.

Yes, I’ve done that as well, but no success. I’ve tried flashing every version of the ardupilot using mission planner, but because the cube won’t initialize

, the mission planner is unable to recognize the board.

In addition, when I looked via the device manager, I discovered a problem with the cube. The device manager says “The Device cannot start”

i am attaching a screenshot of the error.
Once again thank you.

Exactly when I first bought the cube I tried flashing the PX4 firmware using the Q ground control software
but the Qground control was not able to detect the board even back then, Later I decided that I will go ahead by using the Ardupilot firmware and the Cube perfectly worked for more than 10 flights, But now I am having the same issues…
any solution for this?

Maybe the bootloader is somehow corrupted. You may ask for RMA from your reseller.
If you have the SM06B-SURS-TF(LF)(SN)-ND connector and ST-link, you can try to reflash it yourself.