Pixhawk Cube - RFD 900x Telemetry Issues - QGroundControl

I am currently involved in a build that is using the RFD 900X, and am looking for some potential insight into the issues we may be having. We are running the Pixhawk Cube with QGroundControl, and haven’t been able to find a pinout that can resolve the issue with the necessity of multiple RC IN ports. The system itself is running, but we are unable to get telemetry to register in QGroundControl. The transmitter and receiver are connecting to each other, and are giving off solid green lights,

Any help would be very greatly appreciated.

Are you able to connect to the modem from your PC with the RFD modem tool?


1 Like

Yes we have done that

If you can connect with the RFDesign tool are you able to see both modems in the tool?

Have you tried using Mission Planner to connect instead of QGC and what were your results?

How are you connecting the remote modem to the flight controller - which serial port and how do you have it configured?

I want to come back to this problem. I can connect my drone via RFD868+ to mission planner and to UCGS. But with Qgroundcontrol no chance, it stays disconnected. Even with connection menu, I can select 56700baud , but I cannot chanfe5in advanced settings the number of stop bits. It remains on 2 stop bits. Is there a configuration file, where I can change the communication parameter?