pixhawk orange cube does not start

Hi.
I can’t find the pin you mention anywhere.

https://firmware.ardupilot.org/Tools/Bootloaders/

If I make the correct conclusion.I set the boot pin to 3.3v and run the stm program as in the above picture and through usb, I will patch the bootloader to the cube. Please even if anyone can tell me where this pin is located.

You beet me to it, actually came here to post it

Please be VERY careful with this. A slip and your in trouble.

Thank you so much for the instructions. I’ll let you know how the repair works in about 10 days when I get to the school lab and fix it there.

Also this may be a bit easier, Boot0 is linked to R7 and ground. You could connect here on this side of R7 as per the below.

thank you a thousand times, this will be easier than soldering to the chip.

You’ll also have to dismantle this board pictured above from the Cube, do the soldering - you can use 1K, 1.2K, even 2 or 2.2k resistor, it doesn’t matter, whatever you have available, just an order of magnitude smaller then the 10K that’s pulling the pin low - then insert that big 80-pin connector into the carrier board and do the programming. It won’t work if you try without the carrier part.

1 Like

Thank you all. Now it works when I did as you wrote it.

https://drive.google.com/file/d/1iFkIRnlpG-W6-KEGzt7xHyfJS8-1sZnB/view?usp=sharing

https://drive.google.com/open?id=1iGiZ4PBd7N6RwAmnMWppYzjpdXtxDMxT

https://drive.google.com/open?id=1iPiQQvpvK8hTKOgCml5PTGaV-LsRrKhO

https://drive.google.com/open?id=1ierM247NVJAUPCHjYLhbrlB6juZJnMhB

Glad you got it all sorted.

Hello,
Had to experience the same issue as @Jernej_Fajdiga . But I landed up in this mess in a different way. This post is just for information for people who go through the same issue.

Hello Jernej_Fajdiga
can you plz uplord Google Drive File again. photos and videos.i am stuck in this problem. As i followed your instructions but my orange cube is not reponding.

1 Like

Sorry, looks like I deleted the pictures as I needed space on google drive for other files. There is nothing special about the pictures, it just showed how I did it according to the instructions from “MadRC” and “ThePara”.

1 Like

I’m curious if there is a debug board or something similar that might be available where we don’t have to tear open the cube to solder a 3.3v lead to put it into DFU mode… Is there such a beast available? This method worked, and I will treat this cube as a development part going forward specifically to test bootloaders… But it might be nice to have a way out WHEN I break another cube in the future.