pixhawk orange cube does not start

hi i have one problem when i successfully loaded arducopter 4.0.0-rc4 onto the cube and wanted to reconnect it to the computer but the cube no longer responded.

Have you downloaded the correct version ?

How does it look in the comports in device manager ?

I would try a Cube orange version of the daily build and then see and make sure there is the correct drivers showing. I wrote a post on the docs section to help with this.


before installing beta copter 4.0.0-rc4 everything worked fine now after several minutes my computer has not detected the orange cube.
I’ve been flying this controller several times in the last two months. i had downloaded daily versions of copter 4.0.0 and everything worked great. but when i saw the new setting in MP update bootloader i wanted to update it but immediately got an error. after that the controller was still operating normally. but when i downloaded copter 4.0.0-rc4 and unplugged it from the computer and plugged it back it no longer wanted to connect to the computer and also made no sound as usual when i connect it to the PC

is there an option to set the orange cube to factory settings without a computer

Post a screen shot of device manager with it connected.

I tried connecting orange cube to 3 computers but it is exactly the same

is there any other possibility option to restore the original state without a usb cable.

i thought about using FTDI cable

Try re seating the cube on the carrier then forcing boot loader and installing again.

I have had some grange things before when the cube is not 100% seated on the board.

even after reconnecting the cube to the base board, my computer does not detect the cube

does this controller have any button inside to reset the controller to factory settings

No, I would suggest at this point contacting your retailer something seem off.

is there any chance of reloading the bootloader through any other controller such as an arduino and some port on a pixhawk orange cube

however, if the controller does not have a factory reset option. I suggest adding this feature to the cube.

You can’t “factory reset” a bootloader with a switch.

I’ve already learned that. however, I have heard that it is possible to reinstall the bootloader on a cube if I disassemble cube and reinstall the bootloader with some pins. Does anyone know where these pins are for the bootloader to load into the cube.

It’s not that easy.
In theory, you should identify the BOOT pin on the H753 uC and hook it via an 1k resistor to 3,3V to hold it high, so the uC boots into DFU mode. Then there’s an utility from ST that will allow you to flash the bootloader.

I’ve replaced the F4 on one of my Pixhawk 1s and had to go through the procedure, but it happened only once, a couple of years ago, and the memory is fuzzy, sorry

Related? https://discuss.ardupilot.org/t/warning-do-not-update-bootloader-if-using-copter-4-0-0-rc1-to-rc4-on-high-powered-h7-boards/50418

1 Like

thanks for the humble instructions i will try as you described. but I will do this with the help of professors at the electro school to help me if there go something wrong with cube.

If you know instructions. Can you tell me more accurate instructions i will be very grateful.