Pixhawk Orange Cube Not powering Up on Battery

Pixhawk Cube cannot power up when connected to battery port 1 and 2 , however, I am able to power it up using USB ? is the board defective? or i am missing someth

have you tested the voltages coming out of the current sensor ?

|1| VDD_5V_BRICK|IN|5 V|RED/GRAY|Supply To AP from Power Brick

|2| VDD_5V_BRICK|IN|5 V|RED/GRAY|Supply To AP from Power Brick

|3| BATT_CURRENT_SENS_PROT||3.3 V|BLACK|Battery Current Connecter

|4| BATT_CURRENT_VOLTAGE_PROT|IN|3.3 V|BLACK|Battery Voltage Connecter

|5| GND|-|GND|BLACK|GND connection

|6| GND|-|GND|BLACK|GND connection

Yes tested all voltage

  1. 5.3 V

  2. 5.3 Volts

all those things have been tested , voltage is coming upto the connecter.

have you tried with only the power brick plug in ?

Yes , i have tried with the power brick , which came with the cubes as well , still not been able to power it up , only way is via usb.

well i say its not happy send it back to place you got it from

The voltage is coming to the terminals, yet the Orange Cube is not powering up , using th standard power brick which came with it .

What can be done?

How are you determining that it’s “not on”?

Hi philip , i have a buzzer attached and a Sik Telemetry , buzzer usually makes a beep sound , when pixhawk is powered through USB and i can see those lights go up on the rf link as well, none of which happens , when i connect it with standard power brick to port 1 or port 2 .

lets assume that there is a hardware issue, and please talk to your reseller for an RMA, we can check the hardware when it arrives in the office

Hey @Ishan_Bhatnagar
Check for short in peripherals you have connected. This sounds like one of the connected peripheral has a short.
Also, Try to avoid powering everything from Cube. It doesn’t boot if its over loaded too.
Follow below picture where ever necessary.

Mallikarjun_SE thanx for your advice , i am not a newbie , i do not power any heavy load from the pixhawk cube,all loads are powered externally, there is no short on the peripherals , i am only using a buzzer to check power to the cube , which is not ringing,when connected to the power 1 and power 2 , however it rings , when connected to usb.

Alrighty! Follow what Philip suggested.

Just a last hope have you tried reseating the cube on the carrier just is case it’s a bad connection.