Pixhawk orange cube with ads-b carrier board *help*

(Gowtham Reddy) #1

hello,
the firmware is uploading(4.0.0V) successfully but not connecting to mission planner in any bound rates like 57600,111100…etc., it seems like this firmware is not supporting the drivers. i have cross checked with new updated MissionPlanner and new drivers. still i’m facing the same issue. looking for the guys who are using the pixhawk 2.1 orange cube.
i’m using windows 10 pc, and latest mission planner software.
thank you.

1 Like
(Mallikarjun SE) #2

Posting a video of cube lights during upload will give you right solution soon.

(Gowtham Reddy) #3

not able to understand, what your saying.

(Mallikarjun SE) #4

Post a video showing the LEDs that are on cube during the process of uploading.

(Gowtham Reddy) #5

sure will do that.

(Sreenivas342) #6

@Mallikarjun_SE im uploading video link to whats exactly we( me & @Gowtham_Reddy) r gettting issues with cube orange )

1 Like
(Gowtham Reddy) #7

can i know why my post is hidden and marked as span? as i just asked for a question how to solve it.

1 Like
(Mallikarjun SE) #8

Hey! It’s probably because you are new. Are you trying flash Arducopter or Arduplane? Arduplane is straight forward whereas Arducopter for orange is still in beta. You can flash Arducopter 4 beta or latest master on orange cube.
http://firmware.ardupilot.org/Copter/latest/CubeOrange/
This link is for Arducopter choice. For Arduplane, it should work by just choosing the airplane symbol on Mission planner.

(Gowtham Reddy) #9

this firmware is flashing but not able to connect to mission planner. Saying trying to connect in some seconds. i have tried in different bound rates still no use.

(Mallikarjun SE) #10

Hey @Gowtham_Reddy
1)Arduplane or arducopter? and what version?
2)Connect buzzer
3)Are you using “upload custom firmware” option or directly using mission planner?
4)Please read the instructions. It says unplug the board and then click ok.
5)Video seems to be cut. It shouldn’t take that long to detect the device.

(Ian ) #11

You need to make sure you have the latest drivers installed once you have installed the firmware on the Orange.

For Plane you can use the public release but for copter you need to use Beta, It must be 4.0 onwards.

You also need to download the latest Cube drivers from below and install these.

Once you have done this you should have 2 comports showing, Mavlink and SLCAN com port. You must have both showing or your drivers are not installed correctly.

You can check this in device manager .

(Sreenivas342) #12

thank you @MadRC and @Mallikarjun_SE its working now, problem is with drivers.

1 Like
(Gowtham Reddy) #13

It’s working now, the problem was with drivers i have installed latest drivers also dint worked previsoly. now what i did is uninstalled all the drivers and installed latest drivers and did some windows 10 updates. after that it’s working now.
thanks for your support.
i would like to connect with you @Mallikarjun_SE for further help.
my contact number +918885352080
we are from marutdrones.com

(Gowtham Reddy) #14

thanks a lot @MadRC , its working now :slightly_smiling_face:

1 Like