Poor Flying Characteristics after Switching to Dual Props and Updating KDE Firmware

This Vulcan isn’t flying well after making the following changes:

  1. Switched from single T-Motor 18.5" props to dual KDE 18.5x6.3 props

  2. Updating my KDE UAS75HVC ESC’s to v.460247

Flight video is here: https://vimeo.com/408952380/5590333bb3

Pixhawk Cube flight logs are here: https://drive.google.com/open…

I’m not sure which is causing the issue but this was a pretty well-tuned machine prior to the props swap/ESC upgrade.

Who has found it best to roll KDE firmware back to earlier versions?

set the “throttle calibration Mode” to Range and the numbers should be 1100-1940. and check to see if the specific motor is in the drop down on “motor edition”’ that is what we have been doing and it seems to work well. We also went into the mission planner tuning and set the refresh rate at 10Hrz. We have been running the 460247 FW.

All is set per the KDE guide


Changing hardware parts have a significant impact on flight behaviour, especially on propulsion or power side. Re-flashing your ESCs with the previous firmware could solve this issue. Did you asked KDE ?

I have an open ticket to them regarding this and settings that may need to deviate from their standard Cube guide.

1 Like

Maybe a new full PIDs tuning could solve this.
English people have an expression for that, no ?? : “If it works, don’t fix it!” (or something like that) :wink:

1 Like

Hey! Are you sure they run OneShot?

It is their suggestion to set to OneShot

I have the same problem.I had no problems with v3.6.x. I had a problem after updating v.4.x.
I noticed that the MP works better when the ESC Type Normal is selected.

The problem has improved after updating to Copter 4.0.3.