Power Brick Mini v reg spec/current sense?

I believe that I have searched every post on the internet related to the Power Brick Mini, and there are two questions that I can not seem to find the answer to:

1.Will the PB Mini provide current sensing to the Cube? There are multiple threads on this forum that dead end with this question, but never an answer…

  1. What are the specs on the voltage reg built into the PB mini? Specifically the amp output, I understand the voltage is 5V nominal.
    Nothing about the v-reg specs are listed on the product page:
    http://www.proficnc.com/all-products/80-power-module.html

Additionally- from what I understand an RFD 900x can not be run at full power (1 Watt/30dbm) through the telemetry port on the Cube, regardless of the power supply feeding the Cube. RFD 900x draws ~800ma at full power. Can anybody confirm.

I have Mauch v-regs and sensor hardware, and I understand that is a better way to go. But as I have a large pile of these PB minis ( I have purchased several dozen cubes at this point). I would love to know what the specs are and why I have never been able to get a current reading out of them. Another strange behavior that I see is increases in voltage readings (from PB mini) displayed on Mission planner and QGC when under load.

Any thoughts on this would be most appreciated. Thank you for your time.

Note: params as follows
Batt_Monitor, 4
Batt_Curr_pin, 3
Batt_Volt_pin, 1

Thank you,
Josh

Just noticed a typo in my original post, I had it set to
Batt_Volt_pin, 2

Messing around, I changed to batt_volt_pin, 13
and now the voltage doesn’t go up under load.

There seems to be a discrepancy between the parameter values and the Setup>optional hardware>Battery monitor values.

If “HW ver” is selected as “4.The Cube or Pixhawk” then Batt_Vol_pin is changed to 2 and the voltage reading increases as actual batt V decreases.

If I change Batt_V_Pin to 13 this changes “HW Ver” to "2. APM2.5+ - 3DR Power Module and voltage moves in the same direction as Battery actual.

No current is displayed in either case.

First of all what Cube because the Pin’s are different, at the bottom of the power module selection you can Select the Cube Model is Black or Yellow/Orange.

Yes it will read both voltage and current and should just work as long as you select HV module and then the correct Cube, Voltage and Current. .

Ian,
Thanks for your reply.
I have both black and orange cubes. I understand there is a HW type field in the setup>optional>battery monitor screen.

With the Black cube, I’m able to set the following:

Monitor- Analog Voltage and current
Sensor- 7.Cube HV Power Module
HW Ver- 4.The Cube or Pixhawk

This does not provide accurate voltage or a current reading

With the Orange, I attempt to set the following:

Monitor- Analog Voltage and current
Sensor- 7. Cube HV Power Module
HW Ver- 8. Cube Orange

This leads to a frustrating situation where those setting refuse to save. Every time I click over to flight data tab to see if there is a V and C reading, there is no battery data at all. After clicking back over to the Setup tab, the battery monitor config has reverted to:

Monitor- Analog Voltage and Current
Sensor- 0: Other
HW Ver- blank

When I look in the parameters the config is correct, but the setup>Battery monitor will not retain the correct settings. No battery data is ever displayed in the Data tab.

I have seen posts describing this same scenario, but can not see any resolution described anywhere.

*Mission Planner and Arduplane firmware are current from a few days ago.

Thanks again for any input you may have :slight_smile:

Also, I have tried rebooting the cube after making changes in the battery monitor fields, no change.

Hi Joshua,

you don’t need to use the battery monitor screen (this is just a visual help to set the parameters).

Just set the parameters manually in the Full Parameter List.

For the Cube Orange the follwing parameters should work for the Power Brick:

BATT_CURR_PIN,15
BATT_VOLT_PIN,14
BATT_MONITOR,4

BATT_AMP_PERVLT,39.877
BATT_VOLT_MULT,12.02

But don’t expect super precise readings. Especially with a load <10 Amps.

For high precision go with the Mauch Series.

Steffen,

thanks for the information. I had come to the conclusion that it’s best to abandon the battery monitor screen in the setup tab :slight_smile:

I found that if I choose “Other” sensor and use ~200 value in batt_volt_mult , I can get the voltage correct.

The strange thing is that it only works if I plug into power 2, even though the parameters are all for Power 1, and Power 2 in not enabled.

What am I missing here? All the documentation clearly says to use Power 1…

Hi All!

I am having problems with the Power Brick Mini as well.

May I conclude that the current sensing of this device does not work at all?

Thanks!

Jake (From Singapore)

Jake,

I was able to get mine working. It will not really show anything until you get up close to 10amps and greater.

It seems like performing a boot loader update made some type of difference for me, although this doesn’t make any sense to me. It could just be coincidence. I was informed of the need to update the boot loader on the Orange Cubes so i went ahead and did this on all my Orange and Black. The battery monitor screen in the setup menu is still buggy, as the hardware type setting won’t stay populated, but the info does seem to retain in the param file (voltage and current pin).
*Note, I’m able to connect to power 1 and get readings now, still not sure what was going on before…

Hi Joshua!

Thank you for the feedback! I will test it above 10A and see if there are substantial readings.

BTW, I am currently testing it on Cube Purple. Not sure if that will make a big difference?

Jake,
I believe the purple is the same as a black without the redundant sensors. If you select the pins for the Black voltage and current sense, I think that will work for you.
Check this thread for more info on the battery monitor for the black:


It seems like there is some weird stuff going on, lot’s of folks are having trouble getting this to work. Maybe somebody who knows the details better than I do will chime in.