Power Connector molted

New herelink controller system from the box and i started with the update to the latest version

I have tried to update the Air Unit but it was not powering up with the usb connection ( don’t know if that is normal) and connected a 2s lipo with a UBEC to provide 6V to the controller ( 5-12V) the unit was still not powering on , but I notice something got hot and I pulled out the power connector. As it seems the power connector itself was getting hot and is molten.

I am absolute sure that I did not connect it wrong.
20190715_095000

That’s a bit messed up! Contact your reseller

Yes i did he ask to post it here, a bit strange i am going to call him tomorrow

That’s good.

He is correct to get you to post it here. That is always step one.

Ok :smiley:

After 3 months the unit is still in “repair” , for anyone would like to buy one be aware for the repair process. Btw is was a brand new unit defective out of the box they simply should have replaced the unit. I am very disappointment.

Why has it taken 3 months for 1. Them to replace? And 2. Before you contacted me again… I can’t help if I don’t know about it.

Please pm me with details, who is the reseller, and what communication they have had with you?

It’s still not repaired , local seller is MyBotshop they do response on my mail but the unit is still at Hex Technology Ltd , and they say over one month that the unit will be shipped in a few days. And to all other request they don’t respond to my local seller.


Local seller is good, nothing wrong with them.

Ok, I’m familiar now.

I was thinking this was a normal RMA, but this is a damaged unit we are fixing for free…

It’s a difficult task to do this repair. Somehow on your setup you have managed to get high current flow through your ground wire, via the HereLink. It has melted the ground plane on the PCB (talking more than 30A of power)

We are repairing it for free and sending it back to you, sorry for the delay.