PreArm: H_RSC_SETPOINT out of range

Hi All,

Have a helicopter setup running on the herelink. I cant get the system to arm (lower throttle /rudder right) as it saying heli motors checks failed. Also getting this error

PreArm: H_RSC_SETPOINT out of range

But the setpoint is 700 which should be 70% for the castle speed controller governor.

herelink is calibrated, throttle is going the correct way.

Any ideas what else I could have setup wrong. Thanks

The ardupilot wiki says it is a percentage parameter:

Hi Alvin,

It doesnt matter where i set this too from 0 too 1000 i still get this error coming up. Any idea if there could be another parameter linking to this which is failing… Thanks

Im not sure if this value is also linked to the arming error “Heli motor checks failed”

or its not a pre arming parameter at all that is verified.

Could someone please have a look at my param file and see why the RSC is not working.

Ive had it going before but for the life of my cant work out what is going on now. Running Castle Creations ESC in governor mode all setup. Have backup throttle curve which is roughly a flat line. Castle throttle set point range should be around 70% for this rpm range.

Becasue i get this error i can not go into ALT hold or or any Automated flight mode.

Thanks very much for the help. (5.2 KB)

I also have the herelink radio setup like this for channel 8 for the motor interlock

I loaded your param file into a Cube but only battery and radio failsafe stopped me from arming.
Are you using the latest arducopter heli stable?

Hi Alvin,

Yes i am using the latest 4.0.3 stable version. Using the latest Herelink firmware and trying to arm it in QGC all the latest versions.

Have you tried to reset all param to default and set them again?
I guess there maybe bad param or incorrect setup somewhere?