Problem with QGC update

Hello everyone,

There’s already topics for this but has anyone fixed “QGroundContol fully supports Version 3.3 and above. You are using a version prior to that. This combination is untested, you may run into unpredictable results”

Is it still safe to fly?

Can someone tell me when the herelink launcher will be up to date with new versions of QGC? Seem like this has been an issue since January

Please let me know