Problems connecting Raspberry Pi via Telemetry 2 and IO pins

Hello all, I could manage to achieve connection between a Cube 2.1 (on a mini carrier board) and a Raspberry Pi 3B. However, the connection is inconsistent and the console throws a lot of crap and random symbols and characters.

I followed this Link

https://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html

and I set the Cube baud rate (for telemtry port 2) to 921600 baud.

I think that this could be related with the baud rate.

Any help??

Thanks in advance!

First check grounding and pins for correct pinout, then double check the baudrate on the pi

Thanks for your fast reply. The Pi is powered by a BEC, the BEC is powered by the main Lipo that powers the pixhawk cube power module too.

There are 3 wires from the pixhawk cube to the IO pins. Ground, TX and RX. Ground is correct for sure, and the other two I tried to swap them (yes I thought that could be the reason) but it did not work at all.

I have just check that the telemetry 2 baud rate is 921600 and I launch the pi connection with:

sudo mavproxy.py --master=/dev/serial0 --baudrate 921600 --aircraft MyCopter

Any other ideas?

What voltage is the raspberry pi signal level? I assume 3.3v?

I am not sure, it is a Raspberry Pi 3 Model B v1.2

It’s 3.3v so that’s not the issue.

Are you using APSYNC?

Good morning! and thanks again for your help.

No, I am not using these feature yet. In made a new wire to connect the Pi and the Cube to make sure that the wire and connections are not the problem.

However the problem persists. I have not consistent connections with the console throwing crap and random characters mixed with the normal expected outcome.

I have also several messages telling that the connection has dead, no link 1, or link 1 down, and then some re-connection messages.

After several times trying, finally I get a solid and good connection, I the crap goes away and I am getting the normal messages from the cube, also I can arm, disarm and send commands.

what changed?

Nothing really. I just keep trying, rebooting the cube from time to time, finally works. No idea why. I think I will try straight with dronekit and see what happens. I was using MavProxy just to check the connection, arm, disarm and see that everything is OK.

This cube sometimes gives you a lot of satisfaction, other times a lot of frustration :rofl: I will be patient and keep trying.

I will appreciate any help!

I tried to configure Telemetry port 1, but I got the same results. Also I tried with another cube, and same thing.

I wonder if I have to set the raspberry pi baud rate in a different way apart from setting in in the connection string: sudo mavproxy.py --master=/dev/serial0 --baudrate 921600 --aircraft MyCopter

Did anyone connected the cube with a Pi successfully?