Problems with flashing Cube

#1

Hello,

I recently bought a cube black from a reseller listed on http://www.proficnc.com/stores. Placed the order on the 14th of July.

When I tried to flash the cube with Arducopter 3.6.9 using MissionPlanner I never got the sound even though I waited for several minutes. I eventually pressed ok anyway after looking on a few guides on youtube.

I am not sure if it was flashed correctly or not. After rebooting by removing power I am able to connect to it but it doesn’t seem to work.

I see the following message:

Here is a copy of the messages from the message tab:
Initialising APM
Check BRD_TYPE: Failed to init CubeBlack - sensor
Check BRD_TYPE: Failed to init CubeBlack - sensor
Initialising APM
Check BRD_TYPE: Failed to init CubeBlack - sensor
Check BRD_TYPE: Failed to init CubeBlack - sensor
Initialising APM
Check BRD_TYPE: Failed to init CubeBlack - sensor
Frame: UNKNOWN
CubeBlack 003C0034 3138510B 38393830
ChibiOS: d2030d88
ArduCopter V3.6.9 (632be63f)
Initialising APM
Check BRD_TYPE: Failed to init CubeBlack - sensor

It continues with many more messages of:
Initialising APM
Check BRD_TYPE: Failed to init CubeBlack - sensor
Check BRD_TYPE: Failed to init CubeBlack - sensor

I have since then flashed the plane software and then tried to flash the copter software again through mission planner. But now I get some new question I don’t really know how to answer.
(Limited to only one image per post as a new user, but I will try to describe it).
After pressing Copter 3.6.9 Official Quad I get a question with the fields:
Type, Options: Copter, Helicopter, ignore
Version Type, Options: Official, ignore
Platform. Options: Several, among them “CubeBlack”
Version. Options: 3.9.6, ignore
Format, Options: apj, ignore
USB ID, Options: 2 addressed and ignore
Board ID, Options: 9, ignore
Boatloarder ID: Options: CubeBlack-BL, PX4 BL FMU v2.x
Firmwares: Options, 2 web addresses, both to firmware.ardupilot.com/copter/stable/cubeblack/

What are the correct settings here for flashing arducopter?

The cube is currently flashing with a constant color of red / orange several times a second. What does this mean?

So I wonder how I should proceed with flashing this cube to be able to set it up properly. I have seen the service bulletin but to my understanding it was stated sometime in June that new cubes sold by official resellers should not be affected. Could this be related to that service bulletin?

This is the first cube I ever bought so I am not sure that I have provided everything needed. What more information might be of use to help me with this problem?

#2

Please RMA it.

#3

Thank you for your quick response.

I am not familiar with the term RMA, what does it stand for?

#4

return merchandise authorized

Contact you re-seller.

1 Like