QGC crashing when opened (BRU01210730)

After updating to latest “stable” fw (BRU01210730), QGC wont open anymore - app crashes immediately (msg: QGroundControl has stopped). Rebooting Remote Unit does not help, issue 100% reproducible.

Any thoughts @Alvin @philip ?
As there is no fw downgrade option anymore - what to do next?

And to whom can I email the adb bugreport archive?

Problem solution that worked for me:

  • Goto Settings -> Apps -> QGroundControl
  • do “Force stop”
  • clear QGC app cache
  • clear QGC app data (I had offline maps)
  • restart remote unit

Just to note that you may try to force stop Solex as well if force stop QGC don’t work.
I think they may be both working and conflicting on mavlink router. Stop any one of them should work, depends on which one you are using.

That would have been solved by clean reboot - no? But it did not change anything in that regard.

I saw also new crash when I started to download offline maps again - after clearing app cache from previous offline maps (and app was working after clearing the cache).

So it could be very well related to offload maps somehow.

Tried to save offline map, then turn off internet, reboot. The offline map didn’t make them crash. Maybe there are multiple factors causing the problem.

Its not crashing for me as well anymore. What I did:

  • 100% reproducible QGC crashing after fw update
  • cleared QGC app cache (ie offload maps)
  • opened QGC (not crashing anymore)
  • started offload maps download -> QGC crashed
  • reboot and restarted offload maps download in QGC
  • QGC working so far (with offline maps installed)

Here the same, exactly as you described.

Tried to only erase Cache and reboot, but did not help.
After erase of all QGC storage it started working.

Going to download maps again :confused: