QGC reports bad compass. MP says good

(Vince) #1

Didnt know if here is the best place for this or the Cube forum.
Anyway, I have had to disable my internal compass as its getting interference from the gimbal yaw motor. I did the calibration (with only the external HERE2 enabled) using the Herelink QGC (several times). It finishes but the RED-AMBER-GREEN display shows it firmly in the red and suggests to not fly.
When I connect up with MP the offsets seem perfectly reasonable.
Whats going on?
Sorry pic twisted tried to straighten.

#2

Is it only one compass enabled?

(Vince) #3

Yes only the external Here2.
I explained that the gimbal top motor is directly below the cube and probably causing the ‘compass inconsistent ‘ warnings

(Vince) #4

I guess there is no ‘telemetry through ‘ option to plug the Herelink ground unit into a PC to use Mission planner?

(Vince) #5

Could this problem be that QGC does not recognize that compass 2 is disabled?
I would expect it to same as compass3 - not installed?

(Vince) #6

This is the screen I get on the Herelink after compass calibration. It looks like its showing the white dot firmly in the RED after every calibration attempt. I presume a failure is due to high offsets (is there anything else?). However when I reconnect to mission planner the offsets are very reasonable as in photo2. Apologizes for the tilted photos. Ive tried rotating them in an editor but they upload tilted.
Hoping its safe to fly and this is just a QGC/Herelink issue.


(L Kurt Shaw) #7

It’s probably because you have it set to strict.

#8

These ofsets looks ok within good range. So its should be qgc problem i think

(Vince) #9

@hdtechk. That was just on this one occasion. I tried all through the range to see if it affected the results on the QGC but it didn’t.

(Vince) #10

Almost [SOLVED]
As it turns out there was no compass data coming from Here2 unit. GPS was ok. Unit returned for replacement.

I should have figured it out sooner but forgot the Cube has 2 onboard magnetometers. I thought one was on the Cube and the other was in the Here2. Problems started when I put a gimbal on the copter. Thought I has disabled the cube magnetometer and was only using the remote Here 2 unit. Coudnt figure out why the gimbal was still affecting the remote compass.

(Vince) #11

Further update. It was not the Here unit but the cube itself. Not even the carrier but the cube.

#12

So what was the solution in the end?

(Vince) #13

It was a faulty cube unit. Was just replaced.

#14

Can you please cc me on the RMA? I want to investigate this cube.
I’m not aware of any fault in a cube that could cause a compass to incorrectly read.

(Vince) #15

@3DXR. Can you sort this out please?

1 Like
(ben wilkinson) #16

Hi Vince
Yes this one was already RMA a while back.

1 Like
#17

Thanks! All good, and sorted

1 Like