QGC unable to connect. Solex working fine


I’ve been using my herelink system for quite some time now and it’s working perfectly fine with the Solex app.

Whenever I open the Solex app, it automatically connects to vehicle.

But I am unable to connect with QGC. It always says “waiting for connection” and never connects.

I am using latest update of herelink and using copter 4.0.5 on Pixhawk 2.1 Orange. Air unit is connected to Telem1 at 57k baud and using Mavlink1 protocol.

Any ideas how to make it connect to QGC?

Have you shutdown Solex before connecting in QGC?

Yes, I did.
The QGC still says “Waiting for vehicle connection” the time.

No only exiting the App, you have to swipe it away to completely terminate it as well.

You may try to reboot the controller and open QGC at the very first.


Yes, I tried both.
I even tried to “Force Stop” both Solex and QGC from Android Settings/Apps and then tried to open QGC only. Still the same result.

Have you tried to reflash the firmware on controller? Just in case the QGC is glitched.

Hi Alvin,
Yesterday I tried to reflash the controller’s firmware. QGC is connecting automatically now, just like Solex. Guess it somehow got glitched in the first try.

However, QGC shows “QGroundControl fully supports Version 3.3 and above. You are using a version prior to that.”

Any idea how to resolve this?

Also, is there anything which the Solex can’t do, but QGC can? If the functionality and all features are same then I am thinking to use Solex all the time.

I think

QGroundControl fully supports Version 3.3 and above. You are using a version prior to that.

shows because we have some changes to fit QGC into Herelink. Therefore it is different from the official release

The biggest advantage for QGC over Solex on Herelink is that QGC is opensource. You can customize it according to your special requirements. For casual users, Solex should be more suitable.

Thanks for the reply Alvin.
When I use QGC, I get frequent “disconnected” voice notes from the controller. Whereas Solex works rock solid.
Any idea on this issue?

Did it actually disconnect when the voice come out? Maybe you have your Solex running in the background?

You may also try to re-flash the controller firmware in order to re-install the QGC