Quality issues here 2 and here 3

Hi, Can I ask what happened with quality or just im Stupid??? Sorry Im a bit nervous I needed show to potential customer a test copter and it failed right in front of him!!!

Few of your GPSs ended up in trash.

Why in trash? and no warranty repair bcs I sent it out only once and payd extreme shipping cost half of the value of the new one and didnt got replacement so why to send something somewhere if you dont get replacement or repair thats a very long story.

Latest Isssue…

Here 2 - serial port
Here 3 - CAN 1
Kore carrier board Black cube.

After some time of use the HERE 3 flashing intermitently and kicking of all of the onboard compasses… Why Im sure its caused by HERE 3 its simple with cheap chineese M8N all works perfectly. My question is so why to throw that much money out of window if the cheap M8N with I2C performs better??? Sorry Im really disapointed thats not normal…latest param.zip (5.2 KB)

I reseted completely everything uploaded new FW tryed on othe Cube result same it works a bit than it dies and not working.


new symptom:

When the copter is powered up by USB and than battery connected it works… so may be kore carrier board have fault

Have you tested this on other cube? Here2 LEDs going out of sync is mostly software issue. What version of Arducopter are you running?
And Here3 is probably stuck at bootloader. Connect via UAVCAN tab on mission planner and update it. You find all the docs relating to update on docs.cubepilot.org
I’d suggest you to update both Here2 and Here3 with latest bootloader and firmware and run them on CAN.
Arducopter 4.1 beta is out. It includes CAN GPS ordering. So dual CAN should work perfectly.

Okay… so I did some work… spent whole night to troubleshoot…

I replaced the cube on board to cube orange just for sure. Tryed to power the peripheral from othe power supply no change. tryed to run on separate power suplies no change still the same sh.t. Maybe kore carrier board failed internally maybe I dont know.

Situation getting worse… now I can calibrate the HERE 2 and HERE 3 on can but the cube orange onboard compass is kicking off bcs during calibration process the green bar going to end and starting again all arround.

Fine I turned the compass off and went fly… result something terrible YAW balance 18% or any othe % and copter is not holding the heding but turning arround its YAW axis… seem that HERE 3 o 2 is just not OK.

Documentation to this fault NONE…

Probably I will stop use these products… its just too much spent time on troubleshooting of this expensive things with no documentation no support the supliers responses are use less… Im getting very very very mad and seems I will be done with these products. Too much problems also when I go through this forums full of problems and problems all arround… I spend thousands of euro on these products bcs I thinked once it will be OK but it getting worse and worse… thats what I think now… just simple enough Im tired…

First of all this setup made 10FH without any problems… here are some pictures.

I had the same problem with a single Here2 on CAN and serial port. It turned out that the LIION 21700 batteries that I was using wer throwing the compass for a loop. Switched back to a LIPO and worked fine. Also tried running two Here2 GPS units, one CAN and one serial some time back and had issues. I could drop either one and problems went away. I would try running a single unit first to see if there are any issues.

Both GPS look fine now. Yaw imbalance is related to your motor alignment. It indicates that you have angle on motors which is causing 2 motors to work harder than other 2.

Hi, Thanks for respond but no… it was not HW issue after reloading of the FW disapeard first thing when the messeage appeared I checked motor arm alignement it was OK…

Al problems are gone after replacement of the affected here 3… Somehow its causing problems for Cube flight controller…

But there is a bug in 4.1.0 0x400 I:234 cnstring_nan something arround motor test some value in NaN but this is a FW issue of beta version I will make a bug report… thats just for fun.

I will install it on cheap drone where crash will not mean nothing and try to track down the problem…

Thanks anyway for advises :slight_smile: I will proceed with T/S on this GPS unit on other frame :slight_smile: than I will make an update.

I use 7!! Here2 GNSS units all with CAN and some even in dual mode. I had zero issues after updating the Here2s firmware. Very good positioning performance, fast lock and never had to re-calibrate the compass. Disable the Pixhawks onboard compasses, because in most cases they are useless (due to too close wires and batteries).

Why do you use your Here 2 with the serial port? Are you sure you set up the CAN bus properly? Try it with both using CAN and set

Also don´t forget to set NTF_LED_TYPES and both GPS_TYPEs!

If you look on the videos you realize that its configured accordingly the documentation and are followed all recomanedations - instructions. And if you read carefully you find the information that the copter made 10 hours without issue in this config. I use it for prototyping + maiden flights with new features and airframe made few years operation without accident.
And when I start to whining here that something is wrong I tryed usually all the standard ways what Arducopter documentation allows or HW manufacturer allows. Since I build time to time pretty heavy things I need to follow for 100% the documentation. And when HW fails and fails in front of potentional customer on place where I dont have any of spares its a bit frustrating.
This is the only my issue with these products of this manufacturer. Cubes, herelinks, all kind modules perform OK I have issue only with these GPSs which are bit expensive to fail and dont get replacement.

BTW if we talk about numbers I spent on these things in year 2019-2020 5 digit number and its not starting with 1 and I built plenty of compters and plenty of them configured. I know when the HW or combination with SW failed and when its OK. I have till now failed 3 + 1 recent above mentioned units from 24 purchased here units. My issue is thats a bit high for the cost of these things specially when it go wrong and pay shipping back and dont get replacement - thats long and iritating story…

I used always configuration 1x UART + 1x CAN for redundancy and the full feature of double CAN GPS + compass coming with 4.1.0. Yes it works also on current version.

Hah… disable onboard cube compass :slight_smile: yep if you can trust to external GPS fine but not in my case bcs the topic will not start as quality issue but CRASH

Ah, so this is more of rant than a support question. In this case I understand your frustration :grinning:

With the Here3, we have found a similar behavor, the Here3 just shutdown and restart. We have checked and the pins from the CAN connector from the here3 was a quite lose. you have to take out the pins from the can cable, check them and plug it again, and press the plastic that hold the pins inside.


Thanks - checked No fault found :slight_smile: Im done with experiments definitely the unit is faulty. Im looking for waranty repair but I want to pay the shipping by seller :slight_smile: Im not sure if it will work :slight_smile:

At least the prototyping drone survived :slight_smile: