Radio Calibration Problems After Latest Update

I am a mode 1 flyer and with the previous versions of the HereLink firmware I was able to do the Mission Planner/QGC radio calibration and with the exeption of having to reverse RC2 (pitch) everything worked fine

With the latest release I am not able to calibrate in Mission Planner or QGC. In QGC I get a message saying that the thottle channel is reversed and calibration has failed. In Mission Planner when I do the radio calibration pushing the throttle stick forward produces a low value of 1102 and pulling the stick back produces a high value of 1927.

I have tried recalbrating the sticks and SBUS on the HereLink numerious times to see if I have been doing something incorrectly but with no success. I tried reversing the stick movement in the SBUS calibration

I have also tried reversing the ArduPilot RCx parameters with no success

From what I can see there isnt any option to reverse the RC outputs on the HereLink.

Also, I changed the channel map in ArduPilot to suit mode 1 i.e. 1=roll, 2=throttle, 3=pitch, 4=yaw

Any advice would be welcome.

Hi @Brett the device is currently configured for Mode 2. We will push an update with more features in Joystick Config shortly. Afterwards, you should be able to make changes you require.

Thanks for the reply. I’ll wait for the update.

What am i doing wrong?
after the sticks calibration , i only get the throttle movement in qgroundcontrol , the others sticks are not mapped . What can i do ?

I have just checked this and it’s working OK on my end. What’s your setup ?

Also what is the Channel monitor showing ?

It’s worth noting that the screen showing the calibration is what your autopilot is seeing.

thanks for your answer :

on the channel monitor, only the throttle moves …

before the update everything was ok !

my setup : herelink
holybro pixhawk 4

Have you calibrated the RC from the Herelink settings app ?

yes i did , everything is ok sbus too …
may be i should update the px4 ?

yes, the update of PX4 was the reason , i was on arduplane

1 Like

Get a Cube Pascal !

you are right !
any idea for the throttle on a fixed wing ?


I have a similar problem with the radio calibration. I does not work at all after the new update. When I try to do the calibration HW JS CAL nothing happens. I seems that the joysticks arent responding to anything. Everything worked perfect before the new update!

1 Like

Have you tried re flashing the firmware again ?

please start a new thread and we can start to diagnose from there

I have the same problem. Did you solve the problem?

No, I have to send it in to the manufacturer so they can fix it.