RaspberryPi HDMI outputs

Dear all,

we are trying to use a RaspberryPi which processes a depth image in conjuntion with the HereLink to send that depth-image from the UAV to the operator on the ground.

Whereas 1080p works out of the box, 720p is not working. Since we want to reduce the lag-time on the RaspberryPi side, we wanted to reduce the output resolution to 720p. There are plenty of HDMI-settings which can be adjusted on the RaspberryPi (Video options in config.txt - Raspberry Pi Documentation), however, it is poorly documented how the air-unit is set-up HDMI-wise (EDID, CEC, etc.)

Can you give me advice on this?

Cheers

You’ll need to ensure that the raspberry pi is streaming at 720p@30fps. If you have succeed on 1080, the other HDMI settings should be fine on your pi.
You’ll also need to fix the output resolution instead of auto-fit.

to make 720p work on the current stable release you need to update the air unit kernel.

i will give more details tomorrow, as i test with dual hdmi 1080 from a pi almost daily.

this will force both hdmi ports to 1080p
edit your config.txt file with

===========================

hdmi_force_hotplug:0=1
hdmi_force_hotplug:1=1

hdmi_drive=2

hdmi_mode:1=16
hdmi_group:1=1
hdmi_mode:0=16
hdmi_group:0=1

on a side note.

the air unit will lock onto the first valid signal it gets. ie if you have it set at 1080, and change the pi to 720 without rebooting the air unit. it will not work, the air unit “locks” into the last valid resolution. this is to do with fast recovery