Registration fails after update

Received new here link which booted ok and qgc opened. Before anything else I updated the unit. Update worked fine but the registration process failed.
Have tried multiple times with various things found here. Date and time are set. WiFi is all good with excellent reception. Unfortunately I don’t have a second 5ghz WiFi available.

Not sure what to do next. Quite frustrating…

Please ensure that the ip range of your wifi router is not in 192.168.0.x

Hi Alvin, IP range is
IP assigned to it at the moment is…

Are there any particular IP ports etc this needs?

Can you verify are date and time matches the selected region?

Yes - I changed the date and time to my location - Adelaide GMT +930
Time and date are correct for local time.

can you goto
Settings > About > Status, and tell me what the Serial Number is down the bottom of that screen?

Hi Michael,
serial is: 6c83aa0a


ok so to me it looks like rfdesign might have double issued this key.

have you tried contacting them?

Yes, they contacted you (CubePilot) I believe and you asked me to post on here!
So I feel we are now at full circle…

@Eric_Xie yes this is most likely because of the double issue of the one key. if it was any other issue then yes here is the correct place to talk about it.

I actually had to buy a mobile hotspot with 5ghz and second sim before I could get it to update. The units REALLY do not like IP of

Worked perfectly when I did it via the mobile spot.

Finally got it sorted - it was a duplicate SW key, all good now.