RSSI not working

(Philip Smith) #1

I haven’t been able to get a satisfactory RSSI indication from the Cube Black. The receiver is a FrSky R9 Slim+, and the Transmitter is a Taranis QX7 with a FrSky R9M module. The Quad functions perfectly, and it has plenty of range, but 0.0 RSSI. I have tried SBUS and Analog, but must be missing something. Scanning the blogs, others seem to have unanswered problems too.
I cannot find anywhere documentation of the 2.1 Cube Analog port.

RSSI_ANA_PIN 103 8:V5 Nano 11:Pixracer 13:Pixhawk ADC4 14:Pixhawk ADC3 15:Pixhawk ADC6 15:Pixhawk2 ADC 50:PixhawkAUX1 51:PixhawkAUX2 52:PixhawkAUX3 53:PixhawkAUX4 54:PixhawkAUX5 55:PixhawkAUX6 103:Pixhawk SBUS
RSSI_TYPE 3 0:Disabled 1:AnalogPin 2:RCChannelPwmValue 3:ReceiverProtocol 4:PWMInputPin

What configuration actually works?

(Philip Smith) #2

Solved? This works to Mission Planner:

RSSI_ANA_PIN 15 8:V5 Nano 11:Pixracer 13:Pixhawk ADC4 14:Pixhawk ADC3 15:Pixhawk ADC6 15:Pixhawk2 ADC 50:PixhawkAUX1 51:PixhawkAUX2 52:PixhawkAUX3 53:PixhawkAUX4 54:PixhawkAUX5 55:PixhawkAUX6 103:Pixhawk SBUS
RSSI_TYPE 1 0:Disabled 1:AnalogPin 2:RCChannelPwmValue 3:ReceiverProtocol 4:PWMInputPin
RSSI_CHAN_HIGH 2000 PWM 0 2000
RSSI_CHAN_LOW 1000 PWM 0 2000
RSSI_CHANNEL 0 0 16
RSSI_PIN_HIGH 3.3 V 0 5.0
RSSI_PIN_LOW 0 V 0 5.0

Now to find it on the Taranis -

1 Like