SB_0000003 Flight with arming checks set to anything other than 1 prohibited

We are seeing too many logs where arming checks are set at either 0, or at a value other than 1.

If your vehicle will not arm, you need to investigate why! do not take off until you have solved the issue that is causing the arming checks to fail.

The arming checks are there for your safety, and the safety of those around you.

the following parameters are NOT OPTIONAL on Cube Black, Green, Blue, Yellow, Orange
BRD_TYPE,3 #sets the board type to the three IMU board
EK2_IMU_MASK,7 # makes sure that 3 EKF’s run
INS_USE,1 #the following three parameters enable the IMUs
LOG_DISARMED,1 #ensures you can get a log that includes pre-arm information
ARMING_CHECK,1 #Ensures that you run all the arming checks. Your safety comes first

CUBE_BLACK.param (114 Bytes)


I would like to add to @philip excellent advice that if you post to the forums for help, or complain about a crash, or wrong behaviour, and you have your arming checks off, you will not be regarded very highly.
(Thats being very polite).

The arming checks are your friend.
They are telling you something is wrong.
Listen to them, fix them.

And as always, when posting for help, ADD THE .bin FILE FROM THE FC.


Ok I am guilty. Can you help me? I need the parameters for the Here2+ RTK. The safety switch is not available. The manual link in the box is for the version 1 and does not give instructions for parameters. I found it once but can’t find it again.
BRD SAFETY PARAMETERS. I forgot and can"t find them.
Having the old manual link in the box is misleading. I had the whole thing apart per the manual before I realized I have a different model.

Please start a new topic for troubleshooting…

There is no Here2+ RTK yet released…

Arduplane 4.0.1 as tilt rotor vtol configured
And two tilt servo have connected on AUX 09 and AUX 10 according.
I have trimmed tilt servo as per my configuration of quadcopter (0 degree ) as well as for fixed wing (90 degree ) and worked fine with mode changes between quad and fixedwing.
When I try to arm the model with arming check condition to 1,it says AUX 09,AUX 10 trim is not correct and I couldn’t arm it as well.

Can any one help me please.

Best to post as a new topic rather than in the service bulletin area, but I suspect this is related to a check in ardupilot to ensure it’s trimmed correctly.

I suspect your trim is set to 1500?

My trim was 2200

Max is 2000…

OK let it try that. Thank you Philip

1 Like

This cube parameter will also mandatory for pixhawk2 cube also


yes You should be running cube black firmware on all our black cubes.

OK thank you and trim issue also solved.

Looks like you are running fmuv3 instead of Cubeblack firmware.

There are some cases where arming checks need to be disabled.

I have roughly ~30 copters using Pixhawk Cubes, and none of them having arming checks set to 1.

I usually have RC channels check disabled (as my drones usually don’t have any RC reciever on them, unless a client specifically asks for the ability to retain RC control), and I often have to disable GPS check in order to conduct GPS-denied flight testing.

There should probably be some leeway in the use of the word “prohibited” here, as I would hope doing these types of flights does not revoke my ability to receive advice on this forum.

1 Like

@rmackay9, do you have any suggestions for these two things?
Flight with no RC
Flight with No GPS

The first one, I vaguely remember that there is a way around.

The second must be dealt with carefully, as if you hit a failsafe, and have managed to get a gps lock inside accidentally, things can go bad fast… do you have a HereFlow on it?

No HereFlow. We would not use a GPS-based mode I doors. Uses other custom methods to travel in GPS-denied environments.

The problem is not that you choose to or not choose to use a gps mode…

If it’s fitted, Ardupilot is referencing it, and if something goes wrong, your failsafes can kick in… switching you into a gps mode.

I’m hopeful that @rmackay9 jumps in with a suggestion here…

We’ve got a wiki page here on which discusses how to setup a Copter to fly with no RC. At the moment this does require changing the ARMING_CHECK parameter to a value other than 1 (“65470” it seems). Note that this is only for cases where there’s no RC input at all, not even a joystick. If a joystick is present then the ARMING_CHECK can be left at “1” but you’ll probably need to manually set the RCx_MIN/MAX parameters to 1101 and 1901 respectively.

For non-GPS flights the vehicle will probably only be flown in Stabilize, AltHold or Acro and as far as I know the GPS checks are bypassed when arming in these modes unless a Fence has been enabled. By the way, Copter will never switch the vehicle to a mode requiring a GPS (or more accurately a position estimate) when it doesn’t have one. So for example if the user setup the RC failsafe to trigger RTL, if the vehicle doesn’t have a GPS, it will instead switch to LAND.


Thanks Randy

So do all of the above mean that if we want to fly one of our vehicles indoors we should actually disconnect the GPS to ensure that here is no way that the autopilot can select a mode that requires GPS, particularly in a failsafe situation ?

Does it mean that if we then accidentally select Loiter or RTL it will ignore this attempted mode change as there is no GPS ?