Several Motors Won't Spin

Two motors won’t spin after arming.

This is a new build. I’ve set MOT_SPIN_ARM and MOT_SPIN_MIN as I’ve done with these in the past.

These are T-Motor Alpha ESC’s which don’t require calibration. Min and Max are set to RX input range. ESC type is set to “Normal” as I’m using PWM.

All eight motors were spinning last night and nothing has changed.

What am I missing?

What’s your TX output range? The Alphas don’t need calibration, but they still expect a particular PWM range of 1100-1940. Make sure your TX is set to that, or you set MOT_PWM_MIN and MOT_PWM_MAX to that range. You can use Mission Planner’s motor test page to make sure they spin at various PWM ranges.

Only other thing I can think of is to check your servo rail power - if it is not powered properly, you will get unpredictable behavior from your ESCs.

I’m using a Herelink and so there are no “travel/endpoint” adjustments that I’m aware of.

I first calibrated the Herelink sticks and then performed radio calibration in the Cube.

I ended up with 1102/1927 on the throttle stick.

I’ve tried 1100/1940 for the ESC min/max as well as 0/0 for TX-based min/max with no luck.

I have 2 motors that won’t spin now.

Did you check the servo rail power? And do the motors beep when you power on?

I didn’t power the servo rail since the signal wire to each ESC doesn’t contain a power wire.

image

Oh, right, forgot that Alphas just use battery power.

Are the ESC’s getting signal? I.e., do the motors beep when powered on, and then stop beeping?

Yeah, they have signal. I had all eight of them working last night but only six working today. Nothing changed in the interim.

Check your SERVO*_FUNCTION parameters to make sure servos 1-8 are still all set to be motor outputs. Some versions of arducopter have a rare bug that can cause params to reset (fixed in latest release).

Besides this, if your ESCs are getting signal, then your configuration is correct. What are you doing to test if they spin?

I just double-checked all and all are correct.

I’m using the optional menu motor tests as well as arming and running the throttle stick.

Six of the motors work while two do not spin. They did spin last night though.

Uh well my last guess is you can use the Status tab in Mission Planner’s Data page to see if it is actually outputting the appropriate PWMs on channels 1-8 when you are armed. You could also use the tuning graph for this (“Tuning” checkbox at the bottom of the Data page).

No kidding. I’ve been frustrated with this all afternoon. Went to eat. Came back, booted up, and now only 1 motor doesn’t spin. What the heck is going on???

I’ve made a video of what is going on. I’m under the assumption that I have a faulty ESC:

https://vimeo.com/461406700/24e14d56ab

I’ve confirmed via the TM-Link app that the ESC is getting voltage.

We usually run the Alphas with around Mot_PWM_Min 1060 (depending on the Motor / ESC combo).

I would suggest to Set the Throttle Range to 10% or higher in the Motor Test Tab and check again if the ESC is not running.

Last resort would be to check the ESC manually with a Servotester (you need to power the Servotester with a separate 5V power).

I tried 1060 as well as several other MOT_PWM_MIN values but it still doesn’t work.

Here’s another video of the issue:

https://vimeo.com/461501325/6c4f745ff2

Very Strange.

Have you tried connecting it first to your Futaba receiver and than powering on? (This should ensure that the ESCs can read the min point correctly).

Since you have the T-Motor Data, you could check the firmware version on the Alpha ESC and try reflashing it.

I did but it still didn’t work.

I’m waiting to hear back from T-Motor on this.

Try disabling the safety switch ‪and arming protection and see how it is . I wonder if the no signal is messing with the esc on boot.