Siyi ZR10 camera and Herelink setup

I am trying to route the video stream of the Siyi ZR10 gimbal camera through the ethernet port of a V1.1 AirUnit to the ground unit and further. I have been trying my best to understand how the Herelink is managing the network internally to solve this but I have not managed.
I think the cable connecting the camera to the AirUnit is good, and both the Air and the Ground units are at the latest beta fw.
Any guidance would be appreciated!
Can this be done? What could I check?
Is the AirUnit listening for a rtsp stream from somewhere?
The bellow image is a screen grab of what the Siyi app (used to setup the gimbal and camera) allows me to set.

1 Like

Routing is fun. Check out Ethernet on the Herelink 1.1 - #5 by stryngs

If only I would fully understand it, though as we speak GPT-3 in helping considerably.
Isn’t there already in either the air or ground unit some static routing from to
I wonder if I we have root access to the ground unit and if I could do this via CLI.
I do not have the space/weight to add a companion computer nor would I like to do that.

So long as the node you have connected to the air unit has an ipv4 of, excluding .10 and .11, the bridges make it all work.

You do not need a companion computer if the camera can operate on that network. From the GCS you could open a browser and if the camera offered a webapp, where the camera is a random .254, would route you from the GCS to the Camera even though you are on a different subnet.

The catch is with default gateways and whether or not you have multiple routes that might come into play.

I have set the ip of the camera to and the gateway to because there will never be anything more connected to the network.
I installed a apk that lets me ping and I was able to ping from the ground unit.
From another forum post I understood that the camera has a user interface, like usual ip cameras, but the supplier never shared the admin credentials. I install a browser on the ground unit and tried to go to this ip, to just verify that I am greeted by the credentials page of the camera, but interestingly nothing is received. I think I should not be able to ping the camera if the the ethernet cable that I made was wrong in some way but I should still get to the credential page of it.
In the manual of the camera it is stated that I should find the RTSP stream at rtsp:// QGC does not show a video, and the console does not clearly state why so I install VLC and tried to access the stream and the logs clearly state that there is no stream. I guess at this point that the issue, at least for now, has something to do with the camera and its stream.

Hi Camil,

If you are able to ping then it means the tunnel is there, so routing is working as expected. Regarding testing with the video stream and how you were not able to see a stream I would try and set the camera on a network without the herelink in play. The reason for this is to simplfy things so that you can test the video feed, or lack thereof without worrying about any middle issues that may be poised by a litany of things that can go wrong in networking.

If you get the video stream working let me know and I’ll continue to help you troubleshoot. Luck!

I got the stream though yesterday. I am not sure what I did wrong before but I encountered to 2 other issues: There is about a 1.5 second delay of the feed if I connect to the camera directly through a normal router. The video is very laggy (1-2fps) and delayed if I view it on VLC or QGC.
At this point I do not think there are any issue with the Herelink but it rather camera related. I posted this on the Siyi FB group and Ardu discuss where they seem to be active. I will post again here after I find a final solution.
Thank you for the help @stryngs !

Good luck and definitely check out gstreamer for the fastest way to stream video.

Hi @Camil_Muresan

I have the same downstream issue as you did. Have you resolved the issue? It would be really helpful if you can share your findings here.

Thank you.

Yes I did (to a degree). I installed Siyi’s app on the Herelink which fixes it, to a degree. There are many things that are not perfect and for that you can check my posts on the ZR10 page and Siyi app page.

Thank you @Camil_Muresan
I will try doing this. I had one question though; Can we install the siyi based QGC on the herelink controller?

Yes you can. I copied it to a microSD card and the accessed it via the “Downloads” app if I recall correctly.