Sloppy Machine/Need Logs Review - Motor Balance FAIL, Compass FAIL

Can someone please review my logs/params and help me figure out what is going on?
This machine flew sloppy on the first flight but straightened out and was fairly stable after gaining some altitude. I’m not sure why I have a Motor Balance FAIL though.


This is a new build. I’ve been getting the typically EKF yaw alignment errors, etc. and have followed the advice of others in the forum.

These are new motors and the KDE ESC’s are set correctly per their Pixhawk guidelines.

I tuned the machine a week or so ago and had it pretty solid. I’ve since mounted payload and will need to increase the gains to compensate.

Your desired v actual looks good so it does not seem so much to be the PID’s

However your RCout is spread over a wide range of PWM values.
This has got to be affecting flight

Although IMU1 is looking OK and the VIBES are good with no clipping, IMU 2 and 3 have some really noisy spikes, almost like something is rattling against the FC.

That’s interesting. It’s open with nothing touching it.

This is a Cube Black with a Kore Carrier Board.

I’m using SBUS out to control payload functions. Almost every channel is used. Is this what you’re referring to?

Nothing is touching it

Your RCout refers to your motor outputs.
Is the copter balanced?
The thrust from each motor is spread over a wide range of values

It’s as balanced as any other drone that I’ve owned with no issues. Everything is symmetrical with respect to landing gear, arms, retracts, etc.

I installed some more rigid mounts where the arms meet the frame today. I also placed the compass on a taller mast and disabled internal compasses. Recalibrated Accels and HERE2.

My two test flights were great but my logs do not reflect that.

I’ve set my ESC’s per KDE’s guidelines. Could any of this be wrong?!

Disregard the firmware version. I’m on the latest FW.

I recommend you enable all compasses and do the Compass/Motor calibration - this can be hazardous if done wrong, be careful and follow instructions.

I’d enable the Fence, included in settings below - you wont be able to arm and takeoff without a good 3D fix. Once everything is very reliable maybe you could change or disable the fence if required.

It looks like Autotune has fixed up some parameters, and some others were close to what I’d use, but I’d highly recommend setting all these and run Autotune again. Disclaimer: I’m guessing at your prop size but these should be better than defaults.

INS_ACCEL_FILTER,20.00 (maybe try 10 or 15 for this)
FENCE_ALT_MAX,120 <- adjust to suit safety
FENCE_RADIUS,300 <- adjust to suit safety

Copy/paste into notepad, save as {something}.param and load it via MissionPlanner - this save searching and typos.

For a smoother feel try this:
or as low as 0.3 but you need to experiment to see what’s right for you.

In your photo, it looks like the ESCs are just sitting there - definitely secure them if they’re not already.

You motor PWM imbalance looks a bit weird, assuming standard OctaQuad (Quad X8) and correct wiring…
Wait - Kore carrier board - motor order is different!
OK, looks more like a weight imbalance, center of gravity issue.

I just “pinky” tested it for side/side and fore/aft. It did have a very slight tendency to ere towards the rear a bit. I slid the camera gimbal forward to counter.

I’m running KDE 15.5x5.3 props.

I’ll try these filter settings.

Why the fence settings? Did you notice my Futaba’s lost link in the log?

The motor order is set per the Kore. All directions tested correctly during my motor test phase.

MP recommends different multipliers for voltage scaling.

MOT_BAT_VOLT_MAX, 4.4*number of cells
MOT_BAT_VOLT_MIN, I can’t remember the lower multiplier but will look it up

Why the deviation?

I’d always recommend using a Fence, especially while testing. It’s up to you.
I guessed you’d have 15 inch props by the fact it’s a QuadX8 and some of your parameters.

Yes I was thinking as I typed before and decided to leave my ramblings in place, so you’d see I realised it was a Kore carrier. I did check your params to see they matched the Kore motor orders.

As per the new Tuning guide and various discussions.

I made a spreadsheet you can download an use as a starting point for new builds.
It’s not highly professional, but it works.

Thanks for your help!

Do you believe updating from 4.0.3 to 4.0.4 would alleviate the compass issue?

This is great. Going over the spreadsheet now.