Solex TX not connecting with ardupilot

Hi Community, we are trying to connect Solex Tx(Version 1.2.3) in herelink with the plane firmware v4.3.0 with cube orange plus.
We are not using camera module with the setup.

Can this cause any issue with the connection?, Please advice how can we connect arduplane with the solex tx.
It’s saying “Looking for vehicle type : No Vehicle”

Thank you in advance.

Hi, may I know the firmware and hardware version of your herelink controller and airunit ?
Did you try with QGC ?
Also can you share a picture of your set up if you do not mind ?


What is SolexTX doing when you try to connect? If it’s just sitting and showing “Looking for vehicle…”, then it’s not getting any packets from the vehicle. I would suggest trying QGC to see if it behaves differently. Also make sure QGC isn’t running in the background when you try to connect from SolexTX (and vice versa) because the UDP connection can’t be shared between applications.


Hi @Mike_ZY & @kellyschrock , below are the images for hardware configuration of herelink airunit with cube, we are providing 9V to the airunit(verified), both LED1 & LED2 are solid, SBUS is connected to RCIN in the cube, UART is connected to TELEM1.

We are able to connect it to the QGC successfully.

But Solex TX is not connecting.

I have attached images which contains firmware and hardware version of air unit, ground unit. and all of them are up to date.

Please let me know if you need any other details. and what could be the reason Solex Tx is not working, I want to map buttons to short and long press.

OK, so it looks like your hardware configuration works to the extent you can connect QGC to it. Try these steps please:

  1. Open QGC and confirm it’s connected.
  2. Press the Back button and observe the confirmation where QGC asks you if you’re sure you want to disconnect.
  3. Once you’ve closed QGC, click the square button on the “system bar” and ensure that QGC is closed.
  4. Open Solex TX and see if it connects. My guess is that you’re running into conflicts between QGC and Solex.


Hi @kellyschrock, Initially I also thought it could be an issue, so I tried different scenarios,

I restarted the controller and didn’t open the QGC and directly tried to connect the solex tx but it didn’t help.

I started the QGC removed from recent tasks tried to open solex tx, it didn’t help.

I tried to force stop the QGC and tried to open solex tx no help.

I can assure you I’m not using two apps simultaneously to access the UDP port.

Any other advice would be helpful, thank you.

@Mike_ZY, anything from your side, that we are missing.

May I know what showed up after you tap “CONNECT” on your Sloex screen ?
Can you try re-flash or reset this controller unit ?

Hi @Mike_ZY, the above image is the result after pressing the connect button on SolexTx app. there was no difference at all before or after clicking the connect button.

The firmware is already latest.

The app will be reinstall and reset when re-flash.I guess that might be software issue.
So can you please try re-flash the firmware.