[Solved] HereFlow lidar not functional

#1

I built the firmware from the hereflow pr and the optical flow works properly. I am unable to get any response from the rangefinder however. Double checked all parameters and on two different aircraft. Just wondering if anyone has either run into same issue or can confirm proper operation. Sonarrange and sonarvoltage both at “0”
Cheers RB

#2

@auturgy sorry for the posting error. I edited my post but latest master with the pr-can-flow does work as expected when loaded on my hex. Apparently it is a hardware issue with my bench setup. I have done a few test flights and the can flow works quite well.
Thanks, RB

1 Like
#3

Cool!

#4

I’ve had a couple of misplaced posts. The answer above is a bit misleading, the optical flow is working however the lidar is not. I have double checked the code and it is built from the latest changes in the hereflow pr. And I have built the code several times with the same result, flow works very well but no response at all from lidar with a bad lidar health message. I suspected a possible bad hereflow unit so I bought another and just tested with same results so I have to suspect the pr firmware at this point. It would be good to know if anyone else has built the firmware and is experiencing the same issue.
Cheers, RB

#5

Solved

Built with latest PR code and with recent changes both OF and lidar fully functional

Cheers, RB

2 Likes
#6

Update: The flow sensor works very well. The Lidar is working and reports very accurate distance but is virtually un-flyable. It reports bad lidar health as soon as motors are armed and causes erratic flight behavior so I think some tweaking is in order.

#7

Please post a log here

#8

Philip, I have two AUV’s set up the same and they are reacting differently so I will try to sort that out first and when I have duplication I will post logs with and without Lidar enabled.

1 Like
#9

OK, one of the vehicles had a faulty internal compass and was causing most of the grief. I transferred equipment to another vehicle and it now works as expected with both flow and lidar with no health messages. The other which is set up with identical hardware continues to give a bad lidar health message as soon as it starts to gain altitude. I re-flashed the firmware and swapped the flow sensors with no change. The log shows Lidar functioning as I would expect and I don’t notice any flight issues.

00000153.BIN (3.1 MB)

1 Like
#10

Thanks for the update
The team are looking at your logs

1 Like
#11

All who are following this post: The optical flow is rock solid between the altitudes I tested 20 - 30 meters. Looks to me that the CanFlow is on target to be a winner. And did I mention how compact it is?
I now have the unit working to specs on two vehicles, Lidar is functional indoors below 150cm. And as Philip explained at release to be a fully functional system a separate Lidar is required.

Cheers,RB

2 Likes