[Solved] Herelink Air Unit Update Error

Hi,
UPDATE - found a solution, see bottom!!
today I feel very stupid because I seem to fail at every step of setting up my new Cube / Herelink combo.
I cannot get the Herelink controller to pair, I cannot get it to display the frequencies (mentioning this in case it is related), and I cannot update the Air Unit.
I have the Air Unit powered by a power source set to 10V.
When I connect the Air Unit via USB to my Windows 10 laptop, I get a
image
Plugging it in does seem to add this device:

As soon as I start the Flasher app (doing it from CMD to be able to read the output), I hear the Windows USB disconnecting sound, and I get the following:

Afterwards I hear the device connect/disconnect sound a few more times.

What am I doing wrong?

I have a fairly vanilla Thinkpad T470 with Windows 10, a brand-new Herelink system, and nothing is working.

Also, in case this is relevant: The Air Unit seems to be interfering with my laptop’s wifi (on a 2.4 GHz network). While the air unit is powered up, wifi on my laptop is very poor (both are on the same table).

Thanks a lot for all and any hints!

UPDATE: Fould a solution
As recommended by @Sven , I installed the Google USB Driver, and it worked. Strictly speaking, I am not sure I managed to install the driver for the Air Unit, but I had earlier installed it for the Controller, and now trying to do the Air Unit update suddenly worked.

I also get the same result when trying to run the flasher for the controller unit: