[solved]Herelink failsafe setup

#1

Hello.
I am trying to setup failsafe in case when i loose GCS connection. If i understand correctly, can i setup failsafe to triger when i loose connection to GCS? Or should i setup radio failsafe as well? If yes, how to setup radio failsafe with herelink?

#2

The failsafe will engage only if the link fail between the drone and the RC.
I recommande to use Mission planner to configure it. Failsafe is activated by default if i remember correctly.

So, in MP : connect your drone and go to : initial setup > failsafe
In a little block window on the right side called ‘Radio’ you can configure it.

  • Enable always RTL
  • 975
#3

Thats what i normally do.
I tried 2 things.

  1. enable GCS failsafe - not working (after turning herelink off drone wont start RTL(yes i did set RTL), just holds position)
  2. Enable throttle failsafe, however it has no chance to work, because after turning of herelink transmitter the pwm value in pixhawk stays the same, they wont drop below FS value. I guess this should be changed in air unit somehow, but dont know how.
#4

You need to use radio failsafe not GC failsafe.

http://ardupilot.org/copter/docs/radio-failsafe.html

#5

It is very strange…
With the parameters i gave you, i tested two drones with two different Herelink units, and it works fine each time. After turning off the Herelink, the drone immediately engaged RTL.

Connect the Cube by USB & power the drone (without propellers), go in MP at the radio page and test again. Check if all the sticks are moving (green) in the MP bars then turn off the Herelink, the bars should all turn white.

Can you make a video ?

#6

Yes, i can. Here it is :slight_smile: https://www.youtube.com/watch?v=UEhq2jTYh5A&fbclid=IwAR3agApyGRNxgT5niBfGSuBmzn6nKQaaMGJ0MQBCHe4ipkb4a8tl3yQ9H54

#7

Wow … !
:face_with_raised_eyebrow:

#8

You should be getting loss of signal failsafe not low throttle with herelink

Set the trigger pwm value lower than the lowest throttle and test it with the FC Armed not disarmed needs to be armed.

Arm it and then set throttle to say midpoint then turn off RC and look at the main screen for failsafe.

Sbus Signal loss failsafe 100% works on this as I tested it my self.

If this does not work post your Param file and we will take a look.

#9

failsafe won’t engage till it’s armed…