[solved]Herelink internet not working

Herelink just setup for the first time. On the latest firmware image as of a few days ago. Connected to my home WiFi on 5ghz. I can ping the device. But no internet functionality seems to work. I get no maps, and the web browser can’t reach the internet. I tried DHCP and static IPs. Tried putting in airplane to kill the LTE and turned on just WiFi. Nothing.


Check wifi settings make sure it’s not treating wifi as metered connection

Verified that is indeed off.

Turns out the problem wasn’t the herelink. It was my firewall blocking everything. I put it on my phone’s hotspot and magically everything works. I still don’t know what it stopping it on my firewall.


The good thing is that’s probably the hotspot you will use when out flying

1 Like

Well, yes except when I am home and would prefer to have everything on my LAN. I’m a little concerned about what on this controller is making my firewall block the traffic. I haven’t figured it out yet but will report back what I find.