SOLVED! Issue with powering up Cube

(Axel Weckschmied) #1

My setup:

  • Hexacopter
  • Cube Kore Board
  • Cube
  • HERE GNSS
  • Herelink
  • latest firmware

Powering up the copter with plugging in flight battery ends with all LEDs of the Here are off. During powering up they are blinking strange. When I’m powering up the copter at first with USB cable, waiting until boot sequence is finished and then plug in the flight battery all things are ok.
To show how the HERE is blinking during the powering up with flight battery I’ve made a video sequence. Hoc can I post it here?
And what is the problem that the Here ist going off after booting???

#2

Put the video on YouTube and link here?

#3

And post a log

#4

How are you powering the HereLink?

(Axel Weckschmied) #5

with 12V from the Cube Kore Carrier Board

(Axel Weckschmied) #6

here it is:

(Hampus Berggren) #7

The video seems to be private. May you can go to videos and change to official. There is also a middle option, where you can link it official but people can’t find it on your channel without having the link.

(Axel Weckschmied) #8

… ups, try the link above again

(Axel Weckschmied) #9

the log:

cube-powering-up-issue.BIN (1.3 MB)

(Axel Weckschmied) #10

In the meanwhile i’ve done some tests and find out that the issue only occurs when the external compass is enabled. When I disable the external compass and powering up with the flight battery only then it works. It seems that the Here-Module doesn’t boot correct.

#11

That would be very strange if that was the cause.
“Enabling” an external mag has absolutely no physical effect on the mag.
What firmware is this?

(Axel Weckschmied) #12

arducopter 3.6.10

But it is the fact: when enabling the Here modul the issue occurs! Tested it with another Here module - same behavior.

(Ian ) #13

Try reseating the cube on the carrier board.

That’s a really strange issue, any other hardware like Telem or anything else ?

Sounds like something is dragging to power down, I’d try disconnecting everything apart from the GPS and see how it is.

#14

Please show the full setup, something is extraordinary here.

(Axel Weckschmied) #15

(Axel Weckschmied) #16

Will measure the voltage on the GPS1 plug during powering up.

(Axel Weckschmied) #17

The correct position of the Here module is more away from the cube (put for tests only directly on the cube - that does not effect the issue).

#18

Understood

(Axel Weckschmied) #19

Have solved the problem (not find out, what the cause is): Used Here2 module and all works fine :slight_smile: Updated firmware to copter 3.6.11-rc1 (is that the 3.7???) - the issue with Here still exists.

#20

This is a very strange issue indeed.
I’m glad that the Here2 is behaving for you.