(Solved) Still not able to get video in MP


Am I missing something?
I have connected my MP (v1.3.70 build) to Herelink
I have video on HereLink
If I select “Herelink Video” in the HUD, I don’t get a popup window to enter the same IP as I did in the mavlink step

I still cannot get Video in MP

Anyone with video in MP?

1 Like

I’m having the exact same issue.

1 Like

please try MP beta.
there was an issue with incompatibility between gstreamer and gdal.
the beta version should resolve this

1 Like

Solved Michael


1 Like


Problem solved. It’s working for me

1 Like

@champ8242 Thanks for sharing.

@Michael_Oborne Does this has something to do with the new HereLink firmware update? Or it can simply be solved by the beta MP?

Thanks a lot!



Can you test it first on the old FW?

Sure thing, Bart.

It’s 12:30am here. Will try it tomorrow morning and let you know.

Thanks again.

Hi Bart,

I can confirm the beta MP did solve the HereLink video problem even with the old FW. However, not sure if you noticed all of the real-time telemetry data inside the QUICK status window (below the live video window) became pretty laggy once the live video streaming was enabled ?

@Michael_Oborne, @philip
Hi, I have been using herelink (old firmware) connected via UDP to other ground station running QGC for Win/IOS/Android and i never find video/telemetry lag issues. However, I would like to highlight that MP Beta connected to Herelink (with old firmware) via UDP connection has delays/lags in both telemetry and video. Infact, the obvious issue observed was that the video frames were repeatedly missing. Will this issue be solved in later stable versions of MP or is it the video decoding issue and will there be in upcoming stable versions of MP?
Yasir Khizar

@Michael_Oborne, guidance is required.

please show an example of the problem. i have many users who are very happy with the current setup.

it could be an issue with the pc you are using to test.

Hi, sorry for late reply. Here is a link to video captured showing pauses and lags in both video and telemetry . I have used 2 x laptops (core i5 2.5GHz, 8GB RAM) and carried out the pan movement of camera i.e. slow pan movement and fast pan movement. It can be seen that during both “Slow and Fast” Camera Motions, the video is taking pauses while on herelink it is smooth. On the other hand, the telemetry data has lags and updates very slowly. We have also observed that without video streaming on Mission Planner, the telemetry data is been updated smoothly. Your consideration is required on this matter.


Yasir Khizar

the issue looks to be with your pc.
please update your graphics card drivers

@Michael_Oborne, I have lately tried it with system specification as in image attached. checked for driver updates it mentions that it is the latest available. but the video delays and missing of frames is persistent

what power mode do you have your device on? is it a battery device?

Yes, it is a laptop toughpad and ofourse has a battery inside. Can you please elaborate whether streaming can be affected by power source. Are there any requirements like graphic cards, etc for mission planner running on desktop/laptop/win tablet to have smooth video streaming? I must add that using the same laptop, we had no video/data streaming issues in QGC.
Thanks for help/support.
Yasir Khizar

1 Like

i have seen poor video performance when using on low power modes. as video requires more processing power.

Yes, u were right. I have checked the video via udp in mission planner in desktop and i could say that there are no delays. Likewise, no frames were apparently missing from the video. I also checked the same with another tablet and i didnot find any streaming issues. Yet, i am unable to stream error free video in my laptop and i dont know where the problem lies. If i only stream telemetry data in MP 1.3.70, it is totally ok. Contrary to this, if i upgrade to latest MP 1.3.72, both telemetry and video streaming issues start to appear in my laptops. I have checked that the graphic card drivers are up to date.
Yasir Khizar

ok so according to

your graphics card is not supported under windows 10.
so opengl is failing.