Static Notch and Dynamic Harmonic Notch Filters

Hi

I´m trying to set up correct values for Dynamic Harmonic Notch Filter.

Please advice if this is wrong forum for this issue.

I have Cube black, copter 4.0.0 in dji s900 frame, all stock…arms and props etc. 10000Mah battery. That gives me around 15-20 mins of relaxed flight time.
My Gremsy S1 is still waiting to get enought trust to my copter for installation and flight with camera…too many crash in the past.
Herelink RC with small action cam as pilot cam.

Per instructions link , i belive that i have manage to establish the Tht hover value and also i got FFT Gyro / FFT Acco values, see attatched screenshots. Please give your opinion if you see something strange…

Now, im following instructions and have set:
INS_HNTCH_ENABLE = 1
INS_HNTCH_REF = 0,3029282 per Tht hover ±30sec on alt hold
INS_HNTCH_FREQ = ??
INS_HNTCH_BW = ??

should frequency for INS_HNTCH_FREQ to be set following
FFT gyro = 150Hz ? (@9000rpm) or,
FFT acco = 141Hz ? (@8460rpm)

and about INS_HNTCH_BW , im a bit lost here, when i look at FFT graphs, in my understanding it´s around 55-70Hz. Dont really know what to look…please advice.

LOG

first flight tuning notch

Another thing, before upgrading my hexa to 4.0.0 it was flying quite stable, but now when i make even a gentle move, copter swings from side to side like a kite. When turning fast yaw, copter do almost extra 3/4 yaw turn after releasing stick´s. What parameter is controlling the breaking in yaw?
Just did today another autotune with more aggressive settings (0,085) to see if i can get rid of that behavior without any luck.
Diagnosing these symptoms from log´s is beyond my capabilities, so it would be much appreciated if someone would have time to take a look of my log file and give me a hint or a pointer to what direction i should go with tuning.

kind regards Mikko

You’re on the right track.

  • INS_HNTCH_REF: is correct, it’s the throttle at hover. You could simplify it as 0.3 if you want.
  • INS_HNTCH_FREQ: use the larger of the two peaks on the gyro FFT.
  • INS_HNTCH_BW: should be half the value of INS_HNTCH_FREQ.

The smaller of the two peaks on the gyro FFT is the frame resonance. You can use the static notch filter to cut that out as well

  • INS_NOTCH_ENABLE: 1 (enable)
  • INS_NOTCH_FREQ1: use the smaller of the two peaks in the gyro FFT
1 Like

thank you, i will set those values. I actually see now that in instructions it states to set BW hover_freq / 2, just didn´t understood the way it is written.

So, If i enable INS_NOTCH and set the FREQ per smaller peak (76Hz), should i also set INS_NOTCH_BW to half of the value of INS_NOTCH_FREQ ?

(i dont have INS_NOTCH_FREQ1 param in full param list, so i suppose its INS_NOTCH_FREQ)

BTW, i was just looking thru my pid´s and looks like there is something weird going on…what do you think of these values, look´s like way off to me…?

Edit. Just found from facebook…that there is a bug on autotune, so ill set new pid´s…something like this;

Thanks again for your time