Telemetry port not working properly

#1

Hi I have a cube with the edison carrier board which was bought in the middle of 2018 but never installed till now , after 2 days of several attempts i came to the conclusion that something is wrong or at least different from the other regular (not edison boards) that i already have used.
I can not find a way to succesfully link with radios (rfd900 or even the normal old 3dr models) Of course I double checked all the parameters and also the possibility of swapped tx rx wires, mission planner looks like connecting properly but can not download the parameteres from the cube, it just hangs on downloading parameters forever… , in the end I started to think it was a faulty unit and thats why i installed everything on another cube with regular carrier board, and to my surprise the radio comunication worked perfectly.
Is this a known issue or is there a fix for this ?

#2

If you have an Edison installed you can’t use telm2 it is already being used by edison

#3

Thanks for the advice, but I have not installed and Edison on board and the radio is connected to telem1, any other clue?

#4

Just to bump up this issue again, anybody can suggest me something ? I tried also to change from telem port 1 to port 2 bust still no luck

#5

Are you externally powering the RFD module? Also it’ll be helpful if you can provide the param file so others can spot if you’ve missed something.

#6

I tried with external powering and also internal, with rfd900 and also with a 3dr radio, Can not attach the param file since i am a new user but I will write below the relative settings:
SERIAL1_BAUD,57
SERIAL1_PROTOCOL,1
SERIAL2_BAUD,57
SERIAL2_PROTOCOL,1
BRD_SER1_RTSCTS,2 (tried also with 0 in order to remove the flowcontrol)
BRD_SER2_RTSCTS,2 (tried also with 0 in order to remove the flowcontrol)