Telemetry stream but not getting params

Hello everyone,

Context :
I have a setup where I wan’t to be able to connect to a Pixhawk Cube Orange (with Ardupilot Copter 4.3.4) connected to a terminal with a Serial link (from Telem2) which is sending data to my computer via a TCP link. (I’m able to ping in both-way).

Cube Orange <—Telem2 —> Terminal <------TCP link ------> Computer <---- TCP port opened —> Mission Planner.

When I hit the button connect, I’m able to receive the telemetry stream (yaw, altitude etc…) but a windows “getting param 1” is iwithin an infinite upload.

Config :
I’m using the TELEM2 port with the following configuration :

  • Baudrate : 57600,

  • Serial2_protocol : 2

  • Serial2_option : 0

  • All the SR2 stream rate configured between 1 and 5.

  • No FlowControl

  • The TCP link + Cable are OK, since when I am replacing the Pixhawk cube Orange by a Pixhawk 4 (using Ardupilot 4.3.4), I’m able to connect to it , received the parameters (MAVFTP) and then the telemetry.

  • By connecting the Pixhawk Cube Orange directly to my computer (through USB), there is no issue and I’m able to dowloand parameters (via MavFTP).

  • The QGC is sending well the “Request_data_stream” to the terminal but the PIxhawk Orange doesn’t answer to it.

I tried different things :

  • Reinstall MissionPlanner,
  • Reinstall Software on Cube Orange (with different version),
  • Change some parameters ( Serial2_protocol to 1, change SR2 parameters, enable and disable different options).

But at the end, the result is still the same : got this “getting params” message windows and it get stuck to it.
I don’t have any more ideas, if anyone has had the same problem and has other ideas I’m in.

Thanks a lot !