Terrain following too "stepped"

Hi Everyone,
Is there a way to blend a waypoint (Auto grid in terrain mode) with a relative leg so that from takeoff it is a straight line to climb to the first waypoint ?
I have tried to add a leg and select relative for that leg but still looks like it follows terrain which slows the outbound and inbound legs.

Basically the waypoint profile going out and back makes many “steps” that slow the horizontal speed from 5m/s down to nearly 1m/s. This is making the missions really long.

Cheers.

1 Like

copter/plane?? with the newest firmware you can select wp’s as terrain or relative, please give that a try, and test in sitl

Hi Paul,
Did you solve this? I was going to try spline waypoints at the start and end of the survey grid, but havent got to it yet.
Or is it a problem with WPNAV_SPEED_UP and WPNAV_SPEED_DN values being too small?

Hi Michael,
Im using copter. I have just updated MP and will give it a try.

Cheers.

Hi Shawn,
Not yet. Spline was going to be my next option as i use it a lot in survey grid for my copter to flow smoothly to the next grid. Placing them at the start and end of the mission may smooth out my terrain steps but couldnt quantify that statement as my slines have been less than 100m appart…
It is most likely my big hexacopter has bad WPNAV_SPEED_UP and WPNAV_SPEED_DN values.
Its overweight and climbs slowly at full power (not something I want it to do for too long) so SPEED_UP is only 2.5m/s and descent is scary at anything greater than 1.5m/s